Asset as Icon problem


#1

I guess I’m not understanding how Assets work.
In the attached file, I have 2 objects on the Assets bar, DeleteX and project-saturated.
I want to change the the icon for the object in the 3rd row to DeleteX, so I click into it.
On the right, I see the Icon is currently “plus”. I want to change this, so I click on the magnifying glass with lines icon, then click down on Assets. I do not see the DeleteX object. What am I doing wrong?

Buttons.bmpr (135 KB)


#2

Hi @emnrd and sorry for the hassle.

I’ve just gave it a try and the DeleteX asset does show up on my end, as shown below.

I’m attaching your updated BMPR file if needed. Buttons.bmpr (135 KB)

On a side note, if you need to have more flexibility while placing your icon, I would suggest overlaying the Button control with a separate Icon.

Hope this helps! Let us know if you need anything else. :slight_smile:


#3

Hmph…I downloaded your file and it does not behave as it does on your end.
I see a rounded square instead of a X


#4

Hi @emnrd,

Hmph indeed! This is very curious. Which version of Mockups 3 are you using? Via the menu: Help -> About Balsamiq Mockups


#5

image


#6

Thanks for the swift response.

You’re definitely a little out of date - 3.3.14 was released May 2016. Would you download and install the latest version (3.5.16) and let me know if that resolves the issue? Your license key, etc. will be fine.

You can always find the latest version here: https://balsamiq.com/download/


#7

Ok, I’ve got the latest version. Something still not right.

This is a lot to ask … would it be possible for you to outline the steps to setting the icon of a button that is not a standard icon in the library. So, starting with a .ico file on my computer to setting that as the icon on the button.


#8

Sure thing @emnrd - give me a little time to put together the steps. If necessary, we can set up a screen-sharing session so that I can walk you through the process, ok?


#9

That may not be possible with our firewall. Not sure.


#10

Hello again @emnrd,

I ran through the process and have detailed it below but something strikes me - image assets added to a Balsamiq project must be in GIF, JPG or PNG format - we don’t support ICO files which would have to be converted.

Converting a .ICO file to, say, .PNG is simple in Windows - you could use the built in Paint app or use a third party image viewing/editing tool e.g. https://www.irfanview.com/

Once you have the icon you would like to use saved as a PNG file, the steps would be:

assets01

assets02

button01

button02

I’m hoping that the file format is the sticking point here - try this out after you’ve converted your .ICO to PNG or JPG and get back to me if you continue to have issues, ok?


#11

Ah, so the problem all along was the ico. Thanks for your help!


#12

Sorry the penny didn’t drop sooner @emnrd. Thanks for letting us know. Any more questions, you know where we are!


#13

It occurs to me that if one tries to add a .ico file to a project, an error message should be shown. As it is, when I drag a .ico file to the Assets bar, a dialog appears saying “Importing myfile.ico” and all appears to go well. In fact I’ve just noticed that it will let you drag pretty much any file type into the application and display the dialog “Import whatever-file-ext.***”. I tried it with .svg and with .docx.


#14

Hi @emnrd,

We totally agree with that reasoning. The reason we don’t show any error message is that we allow users to store any type of file as non-image assets.

Sorry again for the confusion with this. That being said, we only mention the files we do support as images here but we could make it more prominent in that specific article.

Thanks for sharing your thoughts, my friend! :slight_smile: