Assets loaded partially


#1

I created my .bmpr project on mac version. Other day opened on windows machine and imported assets (material designs icons cca 800+ icons) loaded just partially. When I opened project, it does not show any imported icon, but started to slowly loading in UI, but after while it get stucked and only 1/2 icons loaded. See screen:


#2

Workaround is to clone mockup, then all icons get loaded in mockup, but not all icons gets loaded to assets panel.


#3

Hi, I’m having the same problem as @uxdcz … I imported Google’s material design icons (~750 files) as project assets without problem, but upon re-launching the app, only some of the icons are loaded, and furthermore, they take about 30 seconds to load. When exporting mockups to PDF, those icons that failed to load in-app are also blank in the PDFs.


#4

Just to elaborate a bit more on this problem… Importing 750 material design icons into the project was super easy, but now the project takes 30+ seconds to load every time B3 is launched, and even then the majority of the icons fail to load, as shown here:


Since I can’t use these icons in my project, I would now like to remove them, but it seems that I can only remove assets one at a time by right-clicking and sending them to the trash. With 750 assets, this is totally impractical, so now I am stuck with them.

I’m using the latest build for Mac (Balsamiq_Mockups_3.999.74.dmg), and this problem is a deal-breaker… :-/


#5

Hello,

Can you please try version 999.76 or higher. We made an improvement for that number of custom icons.
The app will still need a while to load the file but the icons should show up.

Please let us know if you still have issues.


#6

Hi Florian,

I just tried this with 999.80, and it worked! All the icons loaded, although when launching the app, OS X definitely gave me a scare with about 30s of the “spinning beachball” while, I assume, the assets loaded. But this I can work with. Thanks a ton for the update!

Burton


#7

Hi Florian,
I can confirm as well as @bjdewilde that it works now!

The only problem is with performance :clock230: - it gets ages (1min + on my i7 machine) to load the project, it almost feels like it gets stucked during the load - maybe let user know that because of lots of assets it will get a while to load. Or better improve speed :wink:

Anaway thanks for such super quick issue fix! Love you guys! Jan