Balsamiq Community Discussion

Balsamic Mockup v3.0.7 compatibility with Windows 10


#1

Hi,

Is Balsamic Mockup v3.0.7 compatible with Windows 10?


#2

Hi riyaaz,

Yes it is.
You should use the latest version though as there are a lot updates since we shipped 3.0.7.
You can download 3.5.14 (which is our currently latest version) here: https://balsamiq.com/download/


#3

Thanks Florian,

Is there a system requirements document which outlines this?
Tech spec doc?


#4

I think until the native version is released, the tech specs from Adobe AIR applies: https://www.adobe.com/products/air/systemreqs/