Balsamiq Cloud is very slow to load a project


#1

Every time we try to load a large object - it stalls at the loading page with quotes. I can take minutes! Can that performance issue be addressed?


#2

I’m sorry about that, Tanya. Would it be possible to DM me a link to the project so that I can take a look?


#3

Thanks @TanyaG!

I took a look and the project takes around 45 seconds to load in Safari and closer to 30 seconds to load in Chrome. I think that this is probably a mix of a slower connection and a large project.

One thing that helped with load times in this project was to go into the Assets view (View > Assets) and then selecting Edit > Select Unused Images. I then deleted those unused images, went to the Trash (View > Trash) and clicked the Empty Trash button. There were actually quite a few things in the trash, which can increase the size of the project.

Doing those two things, I reduced the file size by a 3rd, and the project began to load faster. Why don’t you give that a try and see if it helps with loading on your end.


#4

Ok, I do the clean up - the connection is not an issue at work where we are on a high speed… I know I am using retina quality images and then scaling them down… It would be good to be able to optimize them in Balsamiq…
Thanks about the tip!


#5

Project loading is something we are constantly working on. In fact, we are focusing on initial load right now, so I hope you’ll see some improvements soon. :slight_smile:

Let me know if you continue to run into trouble, Tanya.


#6

I have the same problem but on a much larger scale.
My project takes approximately 15 minutes to load, and only with 21 screens and 9 images
https://balsamiq.cloud/spgdo3v/pftzkd2


#7

I think it may be the same issue for you, @Jheison_alexander_Al. Your project loaded in less than 20 seconds on my 2 year old Macbook Pro with the latest version of Chrome.

Your project is very large for the amount of content in it. I would imagine that it has to do with your high-resolution images. If you shrink those images down and re-import them, the project should load faster.

Try loading the project in a private browsing window to see if that helps as well.


#8

Thanks for your fast answer.
effectively my images are very heavy.
now everything works better