Balsamiq for google drive losing connection


#1

This is on a hard line to the internet and actually from within Google campus. So I very much doubt it is an internet connectivity problem. The odd thing is that I just paid for the google drive version today and never experienced this problem before going with the paid version. Every 20-30 minutes I am experiencing the popup telling me I am offline and it is attempting to reconnect. I can’t work like this.


#2

Hi again @Samantha_Atkins,

So sorry you’ve hit this snag. The last thing we want is preventing you from doing what you have to do!

This sounds like you were having some difficulties to reach our backend server. We tried to reproduce the issue here but it seems to work fine on our end. Is it still happening today? If so, let’s set up a video call so we can try to find the root cause of it.

Sorry again for the hassle here, we’ll get to the bottom of this!


#3

It worked for 4 hours after I posted this last night before hitting the snag again. But today the project hung up in the Chrome viewer with nothing showing in the Chrome developer tools to indicate why. I closed the tab and reopened form Google Drive. This is on Linux btw. The project does not open. It sits forever on a blank screen with again nothing appearing in the Dev Tools to say why. So I went to my Mac where I have a desktop version of Balsamiq and opened the same project from Google Drive without issue.

I conclude there is a real problem with Balsamiq for Google Drive on the web. Guessing. Perhaps a size problem? I don’t know your architecture or whether you have that on appengine but I know appengine is subject to timeouts.


#4

Tried it on Firefox. Same result. To be fair there also seems to be some slowness in Google Drive itself today.


#5

Restarted Chrome and the project opened. Will let you know if I encounter more problems.


#6

Still periodically going offline and thinking a minute or two before the project comes back. Time to plug the mac into the big monitor methinks.


#8

I am experiencing the exact same issues using Balsamiq for Google Drive. I need to use this version so we can have multiple users editing in different locations. However, I keep getting every 20-30 minutes the popup telling me I am offline and it is attempting to reconnect. It then says 'Flash Player 10 required". However I am on Chrome OS so I should have auto-update Flash. Also, it takes about 3-4 minutes to sit and load the project. Please help!!


#9

I’m sorry about this @JeffB and @Samantha_Atkins.

We are going to have Sax (our Plugin Developer) look into this ASAP. As soon as we know what’s up, we will let you both know.

I am sorry again for this, you guys. We will figure out what’s going on.


#10

Sorry for your trouble but glad I am not the only one. :slight_smile:


#11

Hey @Samantha_Atkins and @JeffB,

Sorry again for the hassle here.

As Brendan mentioned, our dev team had a closer look to this issue and determined that we had an overload of our servers in the last days. We are actually monitoring the situation and trying to avoid the issue from occurring again. We’ll keep you informed on the evolution of this.

Thanks so much for reporting it, that is so helpful for us!


#12

Thanks, I hope it can be resolved soon. Very important for our product development and it’s definitely slowing us down. Appreciate the fast response.


#13

Please let us know if you aren’t seeing any improvement over the next 24 hours or so.


#14

k will do, thanks for the support


#15

Just booted me out again. Now it’s taking forever to load…
"Loading project error 6024"
Booted me off:
“You are offline”


#16

@JeffB Would it be possible to share your original file with our Plugins developer, Sax? His email is sax@balsamiq.com. We are still trying to nail down what the issue is. We thought we had it fixed this morning, but apparently not :person_frowning:

We would hold your data in the strictest confidence, and only long enough to diagnose the issue, but we understand if it’s a confidential project.


#17

it is a confidential project, so we would prefer not to. It is pretty image/asset intensive, could that be the issue?


#18

Are there any other options for troubleshooting? Any common threads between us and Samantha?


#19

You caught me just as I was replying, sorry to have kept you waiting!

There are the super-basic troubleshooting ideas (try a different browser, clearing the cache, etc) but I’m wondering if some of this isn’t on our side as well.

Our plugins developer saw some weirdness in the server logs this morning, and he made changes in the hopes of remedying it. I don’t know if Samantha is still seeing issues, but you are, so there is still a problem somewhere.

Big images could have an effect, but it would have to be on a pretty large scale.

Just to be clear: are you being booted out of projects you are working on? Or are you having trouble opening projects? I only ask because I saw a couple of errors opening projects this morning, but I haven’t been booted from a project that I have had open all afternoon.

My use case is going to be a lot different from your use case, so just because I’m not seeing a problem doesn’t mean there isn’t one. But it could help us find an answer.


#20

Thanks for being on top of this.
I have about 150 assets uploaded, so nothing huge.
I am having both issues.

  1. It takes a long time to open and load project data.
  2. I get booted out of projects about every 30 min or so.

#21

Hey @JeffB, let me know how things are today. Also, if you can, can you open a smaller project and just poke at it every 20 minutes or so? We’d like to see if you get disconnected from that project too.

Thanks again for hanging in there with us.