Balsamiq is fully unresponsive


#1

Hi there,
I’m using the Balsamiq Mockups 3 desktop version for MacOS.
It’s worked well since I downloaded it despite crashing regularly.
I’m however experiencing a serious issue now - it doesn’t respond to any command so I can’t open or save a project and I can’t quit the app either.
It’s also preventing me from restarting or shutting down my Mac. :confused:

Since it doesn’t respond to any command, I can’t check the version I am on.

Can you please help?


#2

Hi @Edith,

So sorry for the snag!

Have you tried to force quit the app yet?
This option is available from the Apple menu, or by pressing CMD+Option(Alt)+Esc

Are you able to restart the app then?
If so, please let me know which version you are running. You can download the latest version (3.3.9) here if needed.

Sorry again for the trouble today, we’ll get to the bottom of it!


#3

Hi Virgin,

Thank you so much for such a quick response!
I managed to force quit the app using the path you mentioned - Can you tell I’m a novice on Mac? :blush:

I was able to restart the app without any issues, and I’m on version 3.3.6.

Thanks!


#4

Great news @Edith! :slightly_smiling:

I’d like to make sure the app is running smoothly for you, as it should.
Would you mind downloading version 3.3.9 and let me know if you hit any snag/crash?

We’re also here to help if you need anything else.


#5

Thanks Virgin, I downloaded 3.3.9. I’ll keep you posted if I experience this issue again. :+1: