Balsamiq Community Discussion

Balsamiq Plugin Not working in Confluence

Hello Team,
We have Confluence running in OpenShift, while trying to create a Balsamiq Wireframe Page, we are getting the below error. We use a licensed version of Balsamiq Mockups



Can you please help us in finding the root cause for this.

Hey Roy,

I’m really sorry for the trouble here.

You’re the second case we have seen like this, so we are still investigating the cause.

Can you confirm that the folks trying to edit are in the balsamiq-wireframes-editors group (if this is a non-matching license)?

I’m not sure if it’s helpful, but there may be troubleshooting tips here that could help.

But if you can let me know about your license and whether or not it’s non-matching, we can dig deeper from there.

I’m sorry again for the trouble.

Hi Brendan,

I am not sure what you mean by non matching license, i tried adding the user anyway in the editors group and the result is still the same.
Can you please elaborate on what will actually happen when we try to create a Balsamic page ? Which folder it will try to access and what file will be generated ?

Hi there Roy,

Simply put, a non-matching license would be where, say, you have a 500-user Confluence installation but you have a 10-editor Wireframes for Confluence Server license from Balsamiq where only 10 of your 500 Confluence users are editing Balsamiq projects.

Did you buy your license direct rrom Balsamiq or via Atlassian Marketplace?

To answer your second question, when you add a Balsamiq project to a Confluence page, we add a .bmpr format project to the page as an attachment and also 1 or more .png files which are thumbnail images of your wireframes for display purposes.

In the example for which you posted these images, are you able to add a file (an image for example) as an attachment while logged in as the same user?

Hi Roy,
maybe the permissions on the confluence home folder are not set as they should

here’s a general doc regarding confluence file system permissions Multiple problems due to file system permissions configuration | Confluence | Atlassian Documentation

and a couple of workarounds for home permission problems on confluence+openshift infrastructure

Hello Team,

Can you please tell us which directories need permission for this plugin to be working fine.
what we have noticed is , when we click on “Create a Balsamiq wireframe Page” two files are getting generated in the temp directory in installation folder (/opt/atlassian/confluence/temp) and one .bmpr file is getting generated in the temp directory in home folder (/var/atlassian/application-data/confluence). Please find the screenshots respectively.


we are not sure what happens after that, and the above folders have sufficient permissions as you can see. And as asked above we can upload any attachments from application with out any issue.

And also we use 15 other plugins and all are working fine , and the application also doesn’t have any issue.

Hi Roy, it’s correct, the plugin works using those two directories.
Please make sure that the owner of the files is the same as the user which is running confluence (that usually is not root)

i’ve attached an example of a working sandbox

you can verify the confluence user with:

ps axo user:20,pid,pcpu,pmem,vsz,rss,tty,stat,start,time,comm | grep confluence

Is confluence running inside a docker container or on a virtual/phisical machine?

Let me know

It is running as POD in OpenShift.

Hi Roy, it seems an old bug that should be fixed but maybe it’s recently reappeared. Please take a look at workarounds here: https://community.atlassian.com/t5/Confluence-questions/Confluence-docker-container-changes-permission-of-own-directory/qaq-p/1149841

Let me know

Hi Stefano,

we have some restrictions in openshift where we can’t change the owner. Is there any way we can put this .bmpr file in any other location apart from Temp.

Hi Roy, before doing any customization, i would try to follow the official docker guide for confluence
https://hub.docker.com/r/atlassian/confluence
In particular, if you have the confluence home in a docker mounted (persistent) volume (that’s usually the standard setup) you should check that the host system has a confluence user with UID and GID set to 2002.
Please refer to the “Shared directory and user IDs” section on the linked doc.

Hy Roy, if you need a way to change the confluence /temp directory, you could install a prerelease of wireframes for confluence downloading it from https://build-archives-integrations.s3.amazonaws.com/wireframes-confluence/4.1/BalsamiqWireframesConfluence-4.1.69-2021.09.23.obr

and then you can change the confluence temporary directory using the official atlassian documentation Confluence Home and other important directories | Confluence Data Center and Server 7.13 | Atlassian Documentation

as is by changing the webwork.multipart.saveDir property inside the <confluence-home>/confluence.cfg.xml

Please let me know if this could solve your issue

Hi Stefano,
We are trying to work out the above soultion, but what we actually asked is is there any way we can change the directory where Balsamiq publishes the .bmpr file, so we can create a customised directory in the installation folder, and there we have full permission to change the owner.

And i wanted to update one more thing, This issue only occurs when we try to create a new Balsamiq Wireframe Page, the existing pages which are already using the plugin are working fine and we are able to edit the page aswell. PFB



Just identified that when we are trying to save the project, getting the same SQLITE error.

Hi Roy, for changing where balsamiq saves temporary files, you shoud:

  1. Install the release candidate plugin https://build-archives-integrations.s3.amazonaws.com/wireframes-confluence/4.1/BalsamiqWireframesConfluence-4.1.69-2021.09.23.obr
  2. change the confluence temp directory as described here: Confluence Home and other important directories | Confluence Data Center and Server 7.13 | Atlassian Documentation
    you should edit the <local-home>/confluence.cfg.xml, modifying the property webwork.multipart.saveDir and assigning the value (for instance) /tmp
  3. restart confluence (then the plugin should use the configurated directory)

Hello Team,

Thanks for the support, as discussed , we create a new temp directory which is owned my the same user who is running confluence and installed the above suggested plugin and it started working.

1 Like

Thanks so much for letting us know, Roy!