Balsamiq Wireframes macOS constantly mounts itself

Why does the software keep mounting itself? I click eject like half a dozen times per day. It occurs even after restarts. It’s not causing any issues but it’s super annoying. Can someone shed some light on what I’m doing wrong here? Thanks!

Hi @artismyname

Thanks for the message - this is very curious. Can you confirm that you have the latest version of the desktop app (v. 4.5.5) and that you installed it by simply double-clicking the .dmg and dragging the app icon to your Applications folder?

Can you send us a screenshot of what you’re seeing and we’ll dig deeper. Thank you!

Hi @alasdair

I tried updating (from 4.5.3) but it gave me an error with a message like, “can’t remove file.” However, upon restarting the app the version has been updated to 4.5.5.

I installed by dragging the dmg in to the App folder shortcut within the disk image. I do have the old version on Balsamiq Mockups there as well…don’t know if that matters. Let me monitor it (this new updated version of Wireframes for Desktop) for a day and I’ll report back soon. Thanks!

@alasdair

The issue persists, but I don’t notice it as often. For example, today the app mounted itself again after my laptop was closed (but not off) for the night. I don’t know what other details I can provide.
Thanks.

Hey @artismyname. Alasdair is out today, but this has been a case that we have all been peeking at because it’s so strange.

Here is what I would like to try, even some of it seems redundant.

  • Open a finder window and in the menu at the top of the screen select Go > Applications
  • Verify that Balsamiq Wireframes for Desktop is in that folder (and that it’s not a shortcut)
  • Click the Eject icon next Balsamiq Wireframes in your sidebar
  • Double-Click on Balsamiq Wireframes for Desktop in your Applications folder

After you do that, I’d be really curious to see what happens. Does the DMG mount itself again? Does the app open fine, but it’s an out-of-date version? Is everything seemingly fine?

If it’s the last option, try putting the .dmg in the trash and then emptying it. Does it empty successfully?

This is both very strange and very interesting, @artismyname. I’m honestly excited to see where this goes next. One way or another, we will get it sorted for you, my friend.

We may just have to get weird. :slight_smile:

1 Like

@Brendan

Haha, weird is my middle name :upside_down_face:
I will try the steps you suggested next time the app mounts itself. Just have to wait is all. Cheers!

1 Like

Hey guys,

Point by point:

  • Waited for the app to mount itself again (overnight, laptop closed but not off)
  • Balsamiq Wireframes IS in Applications folder
  • App DOESN’T mount itself when launched from App folder
  • App opens fine and is UP TO DATE
  • Can’t see anything wrong with it at the moment

Screens attached





Wild!

Are you able to see the .dmg file that it’s mounting, @artismyname? If so, what happens if you unmount and delete it?

What about if you open Disk Utility after the dmg has been unmounted? Do you see the file in the sidebar there? Are you able to remove it?

Hi

So I think I fixed the issue. It’s a bit of a glitch, but essentially I uninstalled Balsamiq Wireframes AND Balsamiq Desktop (moved to trash from Applications). Then I located the original dmg for Wireframes and reinstalled the app. No strange mounting now! Thanks!

So strange - but man, I am glad it’s finally sorted.

Sorry about that, @artismyname. Let us know if you run into any other weird ones. :slight_smile:

Happy Wireframing, my friend!