Balsmic has a bug that cost me 3 hours work


#1

A message came up in the lower right corner while working on a mockup. The message still comes up every few minutes in spite of the fact that I have tried all the options the message says to try. Thew message is: "Looks like this BMPR was changed by another user. (Wrong Number) Click here to reload your project or choose “Save As” from the Project menu. If I try to save as using the same name, it tells me I cannot do that as the project is already open. I can save it as a different name but this message pops up again in a few minutes. I did try “Reloading” it but that lost all my work for the last three hours, which I thought was not possible as it was supposed to be auto-saved. I am ignoring the message for now but …


#2

Hi @Boballoo,

So sorry for the snag!

Let’s try to get rid of this annoying message:
Are you sharing the file on a network drive, dropbox or any similar tool? We recommend to keep a local copy of your BMPR file, especially when you’re working on it to avoid this issue from happening. You could always share again the file once you’re done working on it.

Also, are you using the latest version of Mockups 3 (3.2.4)? We recently added a new backup system of all projects locally to an internal folder. You can find that folder by clicking on the “Balsamiq Mockups 3” menu item (or “Help” if using Windows) and selecting “About Balsamiq Mockups.” There will be a link that says “Open local store folder”. Clicking on that will reveal that local folder where you can check for a backup of your project in the LocalProjects folder.

You can download the latest version here if needed: https://balsamiq.com/download

In case you still can’t find a backup of your file, please send me an email to support@balsamiq.com mentioning the version and OS used so we can dig deeper.

Sorry again for the hassle, we’ll do our best to help you with this!


#3

Thank you for getting back to me so quickly. I really appreciate your help as always. I use the program only on my local “C” drive. I checked, and it seems my program is out of date. (3.1.1) I assumed I would be notified when a new version is available. Anyway, I will update it and see if that fixes the problem. I have recreated the work I lost last night so no issue there.


#4

I just experienced the same issue and lost about 6 hours of work. I hit Ctl-S about once every 15 seconds in every piece of software I use. When I did a final Ctl-S and closed Balsamiq last night, I got no warning that there was unsaved work. When I opened it this morning, none of my previous-day’s work was there. I checked the two backups made during the beriod I was working and neither of them contain any changes I made. I never got an error saying that the file did not save properly. I do recall seeing the “Looks like this BMPR was changed by another user.” Statement a few times, after which I would hit CTL-S without a problem. The file is located on a networked drive.

Looking at the bigger issue, your support team just said “We recommend to keep a local copy of your BMPR file, especially when you’re working on it to avoid this issue from happening.”

Now, I am a big fan of Balsamiq but this is infuriatingly ridiculous. Ignorig the fact that many users must/want to keep their files on a server so there are periodic backups of them during the day, if I tell the software to save my work and the software acts like it did, that is a problem no matter where the file is saved. I was using 3.1.9 and have now upgraded to the latest version.

  1. Is there a way to recover my work?
  2. When do you expect to have a version where Ctl-S works as expected?

#5

I’m really sorry about that, Graham. Data loss is the worst thing software can do, and I’m sorry that Mockups lost your data. That’s unacceptable; one of our focuses for the last few months is doing everything we can to prevent it.

The reason Virgin mentioned keeping a local version of the file (while you work on it) is because network drives have a habit of locking files to sync them. Some network drives sync more aggressively than others, so the file is locked more often. When a file is locked, Mockups cannot save it (which is why you were seeing that unhelpful error message). It’s a problem we are working hard to fix. I’m sorry that we didn’t have a fix in place in time for you, Graham.

Because the changes were never committed to the BMPR, there is no way to restore the data. I wish that weren’t the case - it upsets us almost as much as it upsets you. What I can do is offer to rebuild the Mockup. If you want to send us a copy of your project, and a list of the changes you made, we will re-do the work for you. It’s the least we can do in a situation like this.

I am going to reply to your support ticket with a link to this post. If you would like our help, just send us the BMPR and list of changes. We will get started on it right away.


#6

Thank you for your reply. As I said, I am a big Balsamiq fan and your offer to help reconstruct the file fuels my fandom. However, as I suspect you are aware, the type of work typically can’t be done by a third party. So whiel I appreciate the offer, this is a project that I will have to re-start.

Regarding the cause, let me give you some honest feedback and advice:

Feedback: Any discussion of file locking issues is mooted by the fact that your software acts like a user’s work has been saved when it has not. I have worked in software development for 20+ years on complicated systems that have had to deal with file locking issues (either due to backups or virus scans, etc.) but NONE of them would manifest bugs where the system thought it had saved a file and data was lost. At worst, this issue should manifest itself in an error that is returned with I try to save my work. I know of no other piece of software that has ever done this to me. if all of them can figure out if they saved my work successfully, you should be able to, as well.

Advice: Pointing at file locking issues (which are complicated by being on a network but not unique to the networked environment) is like a waiter pointing out that our order is late or messed up because of the kitchen. In the end, one does not care why one’s food is 45 minutes late. Blaming someone else doesn’t change the fact that the restaurant as a whole let the customer down. It is better to simply say “We messed up. I am sorry. What can we do to make it right so you can give us another chance?” (Then go back and yell at the kitchen if it really was their fault. :smile: )

All of that said, you have provided excellent support today and I really do appreciate your trying to make it right. I remain a fan and advocate for you guys.

Moving forward, until you fix this issue, I strongly recommend you broadcast this issue to all users using every channel you have using big bold “URGENT: BUG ALERT” messaging so no one else has to deal with this.


#7

Thank you, Graham, for your thoughtful feedback. I appreciate it, especially, because it helps me do better.

I’m going to talk to the team about adding a save check to CTRL+S to make sure the auto-save is working properly (and has saved). We want to be doing better here, and ideas should come at the cost of folks’ time and work. I cannot apologize enough for that.

I’m also sorry for making it sound like I was trying to shift blame or hide behind context; this is very much our bug and something we did. Other applications work fine with Networked Drives, we should too. That’s why we started making local backups, and why we are constantly refining how the save system works. The blame rests with us.

We will do better, Graham. And it will start by taking your feedback to the team; but it won’t end there.

Please let us know if there is anything we can do to help.


#8

Hi Brendan,

A colleague at Facebook recommended Balsamiq so I decided to give it a try. I was using the demo version this evening for my first attempt at a wireframe for a major project. I routinely saved using Ctrl + S and received a message saying “all changes autosaved.”

I closed my laptop to leave work around 8 PM and figured I would continue it at home. When I got home around 9, it was all gone. Only then did I notice a banner at the bottom warning that it would disappear after an hour.

Fortunately I saved a screenshot, but at least 2 hours of work are essentially lost in case I need to make any edits. Is there any solution you can offer to recover my work?

Thanks,
Matt


#9

Hi @Matt_Sack,

Sorry for the confusion with this! This behavior is specific to our Webdemo, which is only a demo version.

If you’d like to “fully” try out our tool, you can download Mockups 3 for Desktop here, it comes with a 30-days free trial!

While there is no solution to recover your work, we are happy to help you rebuilding it if you’d like. Feel free to send us the screenshot at support@balsamiq.com, and we’ll do our best to help! :slight_smile:


#10

Same thing happened to me.
I’d even read this article before I started, and was being extra careful.
One additional item, this was after I had upgraded from 2.x to 3.x, and had imported some old stale work.


#11

Really sorry to hear that @TayBill!

I assume you are now using a recent version, correct?

Have you checked your local store folder yet?
As mentioned above, we recently added a new backup system (starting with version 3.2.1). Here is the way to access the local store folder where these backups stay.

Sorry again for the hassle with this. Please write to support@balsamiq.com if you need any further assistance, we’ll do our best to help!