[Bug] Balsamiq 3 acts extremely buggy if launched after the app crashes / stops responding


#1

I’m not sure of a consistent method of reproducing this bug, as I am unaware of what causes the app to crash. However, how the app handles the crash is honestly one of the most frustrating user experiences I’ve had to endure.

Environment:
OS: Windows 7 Professional (64-bit)
Processor: Intel Core i7-4770 CPU @ 3.40GHz
RAM: 32.0 GB
Integrated graphics card: Intel HD Graphics 4600

Note: I had 4 different projects open when the crash occurred.

What happens after app crashes / stops responding:

  • Balsamiq 3 process continues to run after I close out of the program, so I have to kill it through Task Manager. Otherwise, I cannot re-open Balsamiq (attempting to open a BMPR file without killing the process first results in nothing happening).

  • After I kill the process in Task Manager, then I can re-open the BMPR file. If, however, I had multiple files open in prior to the crash, then all of the files will re-open. This is understandable, as I know this behavior occurs when re-launching a crashed browser (the browser will attempt to open up all of the tabs that you had prior to the crash). But it’s frustrating because, after all files have been opened, they’re all buggy!

  • If I then close all of the files, kill the process again, and re-launch, the app still attempts to open all the pre-crash files. And it still remains buggy.

  • Perhaps the most frustrating bug is that if you left-click on any element and then try to click off of it by clicking on any of part of the canvas, then the focus remains on the clicked element. This bug happens every time the app crashes and then is re-launched.

  • Additionally, keyboard functionality that normally works suddenly becomes limited. E.g., if I focus on an element, I cannot then use the DELETE button to delete the element. I can, however, click on the built-in trash icon to delete the item. Ctrl-Z also ceases to undo moves.

  • On some occasions (not always), after I try to re-launch and then close out of the now bug-ridden app, I get a weird blank Balsamiq screen. This screen can’t be closed anymore unless I kill the process; it just hangs there. See image below:

  • Once I kill the process, re-launch Balsamiq 3, and have all of the files auto-open again, then if I were to click on another BMPR file to open it up, all the toolbar icon does is flash that yellow / orange notification color; the file that I attempted to open does not open. (I see that someone else has mentioned this bug as well: “Balsamiq 3 sometimes won’t open after if freezes and I force quit the application”)

  • Now, here’s the worst part of it all: even after I restart my computer, the bugs described above almost always persist. As in, I’ll re-open one of my BMPR files, and then all of the files that were open pre-crash will still continue to open. The left-click behavior is still messed up; the keyboard functionality is still limited; the blank screen may continue to appear; files may continue to refuse to open properly.

Balsamiq crashes actually occur more than once a week for me, since I work in it so much. Please, for the love of my sanity, fix it so it handles crashes better than it currently does!


#2

Were you working in Mockups 3 or 2? You mention BMML files, which is Mockups 2 (BMPR is Mockups 3). If you were working with Mockups 2 you should change the category. :smile:


#3

Ah, good catch. Sorry, I meant BMPR (I’ve updated my post). Haven’t worked in Balsamiq 2 since 3 came out.


#4

From working with Mockups I have found that when you are working a project it saves a copy to the Local Store\UnsavedProjects\ folder. It also stores the path to your lastActiveProject in the MockupsSettings.db. When you save a project the lastActiceProject gets set to null. So if the app crashes your work should be saved to a bmpr file in the UnsavedProjects folder. When you launch Mockups again it will read the lastActiveProject setting and load that unsaved project.

From your description it sounds like the problem that is causing your Mockups to crash is something in your project which is being autosaved in your UnsavedProjects folder. Or the unsaved project file is being corrupted during the crash. Then it is being reloaded when you launch the app again. I know it is not a fix, but it might help if you empty or rename the UnsavedProjects folder next time your app crashes like that.

I would recommend going to the help menu -> About Balsamiq Mockups and then clicking on the Open Local Store Folder link. Then from the local store folder either create a shortcut or copy the path so that you can get to it later when you are having problems. Then after a crash, where you are having problems, kill all of the Balsamiq Mockups 3.exe processes that are running. Go to your local store and rename the UnsavedProjects folder to something like UnsavedProjectsOld. Then re-launch Mockups 3. You will need to run it twice. The first time it will look for the unsaved project file, not find it, update the lastActiveProject to null, and then close. When you open it again it should hopefully work for you.

Again this wouldn’t be a fix, but hopefully a temporary workaround. If this does work then you might try opening the most recent project file in your renamed UnsavedProjectsOld folder to see if it causes the odd behavior. If it does then that project file would give support something to look at to diagnose your problem.


#5

Hello @cko

Which version are you actually using? I ask because I have seen several of the issues your reported and we managed to reproduce them and fix them.

First I would ask you to make sure you are using 3.1.2. You can see the version number in the About Dialog.
https://balsamiq.com/download

If the application still opens projects badly please do following steps:

  1. Open the local store folder
  2. Close Balsamiq Mockups completely (maybe even with a forced quit)
  3. Delete the MockupsSettings.db (This kills recently opened projects that we open on start up)
  4. Start Balsamiq Mockups 3 again

Please let us know if that helps. If not please tell us so we can escalate the issue.


#6

Hey,

I updated to 3.1.2 when it came out, so the problems are definitely still occurring in this version (at least for me).

The next time Balsamiq crashes, I’ll try the above steps and let you know how it goes. Thanks!


#7

Hi @cko

When you hit the issues again can you please send us the log file that is also in the local store folder? The log file gets reseted when you start Balsamiq Mockups 3.

Some of the issues you noticed are connected and are caused by the same issue.
When you can no longer deselect a control and some keyboardshortcuts are disabled the application thinks you have either a different control selected or thinks you are still in a specific editing mode.
Do you remember when this happened?

Does the issue occur always with the same project? If so could you share it with us?


#8

Hi all. I have the same irritating problem with the last version. I have a big project with many mockups and it seems that it is too much work to handle for balsamiq. At some point the program crashed then the changes were not saved, the project file corrupted. I have tried several times to reopen the program, even re-starting the whole OS but still the Balsamiq program is unable to work again properly since it tries again and again to open the corrupted project files, which obviously does not work anymore, so I wait and wait while loading for nothing. At the end I have to kill the process since I cannot work anymore.
I tried your solution of deleting the db file. Let’s see if we can recover the work from the old corrupted project.
Please remove this automatic re-open option or do it optional. It creates a non-working loop with corrupted files.
I have the log file saved. I can send it to anyone interested.

Cheers,

Rosa


#9

Hi everyone,

I also have some similar issues, but only sometimes and not so harsh as some of you.
But it happens regularly, that Balsamiq crashes, and some of the last changes are discarded. I can’t figure out, what is the logic behind, but only some random changes are not saved, and some are saved. For example, once after crashing approx. 50-60 % of customized icons were deleted, and in the symbols and mockups there were nice squares instead of them.
Also it happens sometimes, that after crashing it’s not possible to start Balsamiq anymore, but it helps to restart the laptop.
So my issue seems to be not too bad, but still after every crash I have to have a look if some changes were discarded.
And I haven’t saved the log file, next time I have a problem, I’ll do that.


#10

I am really sorry @Rosa_Castillo and @Liubi

@Rosa_Castillo would you be so kind and send us the log file to support@balsamiq.com? I am eager to take a look at it.
If you send us the corrupted project we can see what we can restore of it.

Regarding the crash:
Did it happen after importing a lot of assets or a very big symbol library?

Regarding the lost changes @Liubi
Did you have a warning in the bottom right corner that save operations failed? Do you store your file on a dropbox folder?

Thank you


#11

Hi @Florian_Brauer,

maybe my problem could be related to a big symbol library, as I’m working on a template for my colleagues.
I stored the BMPR file on my hard drive, so only I had access to it. And there were no warnings, I’m pretty sure. The software was not responding any more, and I had to close it (I didn’t have to kill the process).
That’s why I haven’t checked if something was missing in the mockups, has sent the file to my project leader, and then got the feedback that the templates look strange with those black squares.

But I think that was the biggest issue I had, ususally my widgets were not deleted (or I haven’t noticed that really :smile: )


#12

I sent already the log file. Yes, the crash was after importing a project from a zip with 18 Mockups and many images into another bigger project. We are trying to implement all GUI interactions between different parts of an application. The small projects with up to 20 or 30 Mockups work well, but as soon as we merged them into a big project, in order to generate a complete interactive PDF, Balsamiq has problems. Maybe we are stressing the program with so many Mockups and pictures. Is there a limit in the number of Mockups you can work with, inside the same project, in order not to crash the program? Meanwhile I said my job-colleague, who is also quite frustrated with Balsamiq, to work only on smaller projects.

Thanks for the help.


#13

Hi folks, I would like to send my corrupted file. I have had the exact same issues as the folks described above. I was working with a rather small file, no symbol library.


#14

Just as a heads up if somebody has a corrupted file like Sa_brina.

How can you recognize that your file is corrupted?

  • When you open the bmpr file you will keep seeing a black screen and a loading bar.
  • After a while you will get an Error #3123

Feel free to send such a file to support@balsamiq.com. We will recover what we can from the corrupted file and send the restored file back to you.


#15

Hi, folks. I have the same problem here. I’ve changed the bmpr file to another folder, and some days later i’ve opened Balsamiq, that showed an error message (like “missing file”), and then I remembered that changed the file folder. Recreate the original folder (same path and name), and Balsamiq start to show a blank screen, no way to use it. I’ve tried to delete the MockupsSettings.db, but Mockups still not working properly.

Environment:
Balsamiq 3.2.4
OS: Windows 7 Professional (64-bit)
Processor: Intel Core i7


#16

Ack @clacorte, I’m really sorry about that!

I’m not sure what is happening there, but we are going to run some tests here to see if we can reproduce it.

Would you mind backing up your local store folder (copying it to the desktop should be fine) and then deleting it? Mockups should recreate it on next launch, and that may allow you to get back to wireframing.

I’m sorry again about this. We will get to the bottom of it!


#17

Thanks for the quick response, Brendan.

I’ve tried deleting the local store folder, but the error continued - a blank screen appear, except the menu, that is visible - just like the screen that i’ve uploaded.

Now i’m trying to unnistaling the app and clean the registry - the error continued. When i uninstall, clean the registry, and reboot the computer, Balsamiq Mockup works until I open my bmpr file (it has about 30 screen mockups - it’s not a big project).

I was thinkinf if it could be about the 32 bit compilation of Balsamiq Mockup - my computer runs Windows 7 64bits.


#18

That’s really odd @clacorte

Would it be possible to share the BMPR file with us by sending it to support@balsamiq.com?

We take user data security seriously, and wouldn’t share it with anyone outside the team. It may help us figure out what about that file is crashing mockups.

If you have another project file, try double clicking on that one to open Mockups. I assume, since you reinstalled, that you are on the newest version 3.2.4, so Mockups should only open the file that you double click on.

Again, terribly sorry for the hassle here.


#19

Hi, Brendan. No problem, I’ll sendo my bmpr file to balsamiq support. I’m using version 3.2.4 (and i’ve tried to install older ones just to see if the problem was with the last versions). I’ve also tried to open from another project file, really simple one, with only 1 mockup, but the problem persists - blank screen, except for the menus. An interesting thing is that visualization mode (full screen presentation) works properly, but when i go back to design mode the blank screen come back.

Thanks again for you help.