Bug: Closing All Windows Opens Blank Mockup


#1

Hello! Long time no visit, I know. I think I found what is hopefully a bug - unless it’s an Air thing.

At the end of the day I often use the right-click on the task bar to ‘close all windows’ - in most programs this prompt me to save any unsaved work if necessary and then close all the windows.

This is not what happens for Balsamiq. It does close all my open mockups - by the end of the day I usually have two or three open - and makes sure they are autosaved - which is perfect. But then it opens a new blank mockup, which I must then quit out of. (I actually have tried and cannot use the “close all windows” link at this time.

Playing around a bit, this appears to happen only when I open mockups by clicking on an existing mockup rather than opening the program directly via the task bar or the start button. (Yes, windows 7). But as I normally open the mockups directly, this is a consistent struggle for me when I do try to close out of the program quickly and go home.


#2

Hey @RaeHanley

Sorry about the weirdness here.

I’m having a heck of a time reproducing it on Windows 7 / Mockups 3.4.4. If you can give me an idea as to how big the projects are when this happens, that will help me dig deeper. Also, how long have the projects been open before you close them?

If you can, sending the BalsamiqMockups3.log file found in the local store folder may also shed some light on the issue. Just make sure you send it as soon as you close all the projects. If you re-open mockups after you see the bug, the log file gets erased.

Thanks for bringing this to our attention, Rae. Let’s see if we can figure out what the heck is happening here. :slight_smile:


#3

Can do - (Oops! I just updated to 3.4.4 and luckily? it still happens.) Where should I send the log file?

The two files I have that can consistently pull up the error are 2201k and 737kb. I haven’t exhaustedly tried it with other files, but today is not the first day this is happening.


#4

Ok, I’m both happy and sad that 3.4.4 didn’t fix the issue. :slight_smile:

Shoot the log over to support@balsamiq.com and I will start digging!