Balsamiq Community Discussion

[bug] Copy bitmap to clipboard

Hi Balsamiq,

Copy bitmap to clipboard function doesn’t work neither with keyboard shortcut, nor with Edit menu. Though, a notification on placing the image to clipboard does appear in both cases.

I’d prefer the reverse behavior :sunglasses:

Win 7 64bit, Chrome browser

Hi @Alexey_Kolchenko,

Thanks for the report. This is a curious one! If I copy the bitmap I am not able to paste it into some applications (e.g. Windows Paint and Photoshop) but I am able to paste it into others (e.g. Microsoft Word).

We’ll dig into this and work out what’s happening here. Bear with me and I’ll get you an update as soon as I can, ok?

Alasdair, thank you for clarification. I’ve checked, indeed, some apps does allow pasting, but some doesn’t.

Hi, i have the same problem. I select an area, after i select the Item “Copy bitmap to clipboard” i the Edit menu, and i’m not able to paste it in others applications (, word …)
I tried it in IE browser and Chrome. (W10)
Thanks for your answer,

Hi @Benoit_Louzeau,

As for now, for the small wireframes you can use third-party tools to get a part of a screen as an image. It’s the most fast way to get an image. I personally use Postimage.

For the big wireframes, which are go beyond a single screen, you can use
Project > Export > Current Wireframe to PNG...
which is a bit longer and boring old-school way :slight_smile:

1 Like

Hi @Benoit_Louzeau,

Thanks for the post. It’s an issue we’re investigating - long story short, it’s to do with Javascript and security. Seems to be a bigger issue on Windows than macOS. I’ll keep you updated with any developments.

1 Like

Thanks. myself, i work with the standard windows 10 tool (Capture) and it’s works well :wink:


:+1: anyway, having right functioning CTRL + SHIFT + C is needed feature in Balsamiq

1 Like

+1 - Not copying here. Needed.

1 Like

I’m still having the same issue. Can it realy be the case that two years after learning of the bug it’s not fixed? That’s not impressive. This is the most critical function to me and it works on some days, doesn’t work on others.

Hi @GeoffSnowman and sorry for the lack of updates on this one.

Our development team looked into it but unfortunately, we are limited by the browsers in this situation so there isn’t much we can do to improve it.

It only affects our web products on Windows so a possible solution would be to use our Desktop product to edit your Balsamiq Cloud projects and use the “Copy Bitmap” option from there, but we understand that it may not be an ideal workaround for you.

I’m really sorry that I don’t have a better answer for this one, we’ll be here to help if you need anything else.

Geoff, I’m currently on v4 and copying works as intended.

Still I need copying images from the other apps quite frequently, so the fastest way for me is Postimage app. When I need to copy some fragment, I just press PrnScr, draw a rectangle and press Ctrl + C to get it in the clipboard.

Hope this helps

Do you know what circumstances cause it to work / not work? Sometimes, it works just fine for me. Sometimes, it doesn’t work. When it doesn’t work, trying again doesn’t help. Sometimes, rebooting fixes it and sometimes it doesn’t. If there is something I could do to make it work, that would be helpful.

Hi @GeoffSnowman and sorry for the late reply.

I’ve just checked again with our dev team and it’s hard to determine the root cause of the issue in this case.

Would you mind trying something the next time this bug shows up: If “copy bitmap” doesn’t work, can you try exporting the wireframe to a PNG to see if it works?

Also, which browser are you using when this occurs? Have you tried a different one by any chance?

Thanks for your help!

The weird thing about this bug is that the feature works for me perhaps 70% of the time.

I’ve experienced the bug in Chrome, FireFox, and MSFT Edge. When it doesn’t work, it seems to not work in any browser. Although my primary browser is Chrome and I have only tried it in the others when Chrome has already failed.

I’ll try a few things when I have time. I can open Chrome developer tools and see if I notice anything in the console and I can experiment with trying different wireframes and see if there is something wireframe specific.

I also have a screen shot tool called Greenshot loaded. I’ll try unloading it and see if that makes a difference.

Export to PNG ALWAYS works, even when grab to clipboard doesn’t.

1 Like

I’d say it’s not a bug, rather the image format from a browser’s clipboard. Once I get the image in the clipboard, some apps accept it on paste, while the others don’t.

I use Chrome browser, and MS Word / Google Docs always accept copied image, while Irfan View doesn’t.

I have a different experience, where sometimes I can paste into MS Word and sometimes I can’t. I’m also using Chrome.