Bug: Copy - Paste Appears to Paste 2 Copies


#1

Every time I copy a component on a mockup and then paste it, it seems to paste two copies instead of just one. If I don’t catch this, it really bloats my mockup file size. Has anyone else seen this bug?


#2

Hey again, @LexUxDPM.

Something weird is happening here, and I’m sorry for any headaches this is causing you.

Before we dig into this, I have a couple of questions:

  1. Are you on the most up-to-date version of Mockups?
  2. Does this problem persist through application restarts?

Also, if it’s possible, would you be able to send us a copy of your project so that we can try to replicate the issue on our side? We definitely want to get this bug fixed.

You can email your project to support@balsamiq.com

Hang tight, Patrick, we will do everything we can to figure out what’s causing this!


#3

Are you referring to Assets @LexUxDPM ?

I’ve had the same occur in one of my projects (up to date now but this occurred a while back on an older build)

Probably from dragging a file into two separate mockup pages direct from Windows Explorer, rather than drag from the Assets bar for the 2nd occurrence.


#4

There was a bug where dragging symbols and assets into new projects would sometimes result in them being duplicated.

We think we fixed it, but if you’re up-to-date and still seeing it, please let us know. We want to squash it once and for all!


#5

When this was happening, I was on 3.4.2. @Ryan had some good info that may be most of my problem. I was dragging mockups from one project to another and copying-pasting from one mockup to another (both within the same project and across projects). I just updated to 3.4.4 this morning, so I’ll keep a watch and let you know if it’s still happening for me. Thanks @Brendan for your help. I appreciate the quick response.


#6

I’m having a similar problem with Balsamiq Cloud, but only one one computer I use.


#7

Hi @RenMac,

Thanks for the post - it’s curious that the issue is limited to a specific machine you are using. Can you try clearing your browser cache (if you are not sure how, see: http://www.refreshyourcache.com/en/home/) and let me know if the issue persists?

You could also try using an Incognito/Private browsing window to see if the problem goes away - if so, it’s possible a browser extension/add-on/plug-in is interfering.

Let me know how it goes and we’ll get to the bottom of this for you, ok?


#8

Hi Alisdair,

I’ve tried clearing the history and the cache and the problem is persisting.
I’m using a Mac with Safari 11.0.3. I’ll try using Chrome instead and see if that fixes the problem.


#9

Thanks for sharing more details, @RenMac.

We’ve been able to reproduce the bug in Safari and the fix will go live with our next update for Balsamiq Cloud. In the meantime, using a different browser will give you the expected result.

Thanks again for the report! Anything else, we’re here.


#10

Double paste is currently happening for me in Chrome on Mac with the Google Docs cloud product.


#11

Amazing, as soon as I report the bug it stops doing it… you guys are quick! :slight_smile:


#12

Good to hear that it is solved @lgpdx but please let us know if this bugs you again. We’re here to help!