Balsamiq Community Discussion

[Bug] Copying mockup with symbols to other projet duplicates the symbols/assets


#21

I’m using 3.1.7 and it very definitely DOES NOT prompt for copying vs replacing - it just does it (i.e. re-adds the symbol set). As a result, my project, after doing a bit of cut n’ paste from another project now has 5 copies of the bootstrap icon set. This is exceptionally annoying.


#22

Hey @Dave_Richard, this is very much a bug we are trying to track down and squash. We thought we got it but if you are still having problems, we must have missed something. Do you mind shooting an email to support@balsamiq.com so that we can dig deeper?

And if anyone else is still having this issue, please email us and let us know. We know how annoying this bug is and want to fix it completely!


#23

I still have the problem as well, but it is unclear what triggers it.

It will duplicate some of the assets, but not all of them. I haven’t changed the name of those assets nor the assets themselves.

I’ve tried to reproduce the problem with a simple example but I haven’t had any success.


#24

I have a very big problem related to the current issue, which is destroying my very very big project file… :frowning:

This is the steps and the final result I am facing:

  1. I am working on a very big project with around 90 mockups and 40 symbols. As I worked on the project I created new versions of the file to track changes.
  2. I made the mistake of copying a part of a mockup from an older version of the file to the current one.
  3. The copied part included a symbol and it copied its entire Symbol Library (which had the same name of a Symbol Library I have in the file).
  4. I checked which was the old one and deleted it as I did not need it.
  5. I copied again other part of another mockup to the file and again it brought the entire Symbol Library. This time by mistake I deleted the wrong Symbol Library (i.e. the newer one). Action which, I discovered can’t be undone :frowning: :frowning: :frowning:
  6. I checked and cleaned the entire library and started to updated the mockups
  7. Every time I make a copy-paste of whatever element (within the new file) it copies again the old Symbol Library from the old file. I learnt not to do it, but sometimes I forget and make it. This started making crash the entire file, so now I am wondering how to save my 90 mockups… :frowning:

…I hope you solve this a day because it is really annoying!!


#25

Yikes, I’m sorry about that @aledis. Let’s see if we can get that fixed ASAP.

Are you running the newest version of Mockups? (https://balsamiq.com/download)

If so, would it be possible to send your project file to support@balsamiq.com so that we can take a look at it. We wouldn’t share your file with anyone outside the tech team, and keep it only long enough to diagnose the issue.

Again, I’m sorry for any frustration this is causing you. We will get it figured out!


#26

Is there an update on this bug? We recently upgraded to desktop version 3.2.4 and this still occurs. Whenever I copy a symbol that’s being used in a mockup the entire symbol set is copied. Curiously I cannot reproduce this in a newly created project so it seems something at one point messes up the symbol library.

You do get a dialog window ‘Replace confirmation’ after the copy asking if the symbol set should be updated with options to ‘skip’ and ‘replace’. Both options result in a full copy being made though. This dialog does not appear on normal working project files and I’m actually not sure what triggers the dialog window to appear.


#27

Hi @frank_v,

Sorry for the snag, this shouldn’t occur anymore.

We recently implemented a new way to move single symbols from one project to the other by drag and dropping them. This shouldn’t drag the whole symbol library with it. Would you mind trying this instead of copy/pasting the symbol?

Also, if the issue persists, would you mind sending us your BMPR file to support@balsamiq.com so that we can try to reproduce the issue here in case it is specific to the project you use? We will keep your data in the strictest confidence and only long enough to try to debug your issue.

Sorry again for the hassle with this one, we’ll get to the bottom of it!


#28

I confirm that the bug I initially mentionned is not reproducible. :+1:


#29

Just downloaded Version 3.3.3, drag & dropped a mockup from one project to another, assets are still being duplicated.


#30

I’m sorry about that @dyang.

Would it be possible to share the file with us so that we can have a look at it? We would hold your data in the strictest confidence, and only long enough to diagnose the issue.

If that works for you, you can send it to support@balsamiq.com, and we will start poking at it. Sorry again for any hassle this is causing you in the interim.


#31

Will do. Trying to reduce the file size first so it fits in the mailbox.


#32

I have a very similar issue also within the same project, i.e. copying and pasting a part of a mockup which contains assets or symbols within the same project (in the same / different mockup) will make appear the 'Replace confirmation" popup asking (for each asset) whether to replace or skip.
If ‘skip’ option is chosen a new copy of the asset will be made. If ‘replace’ option is chosen the images will be updated one by one.
For me this step is both useless and annoying. Normally when I make a copy of a section I just want it to appear once more, referring to the same assets as the original.


#33

Sorry for the trouble with this one @aledis.

Do you have multiple projects/BMPR files open when that occurs? We just found a bug where copy/pasting with multiple projects open triggers the replace dialog.

Are you seeing it when only one project is open? We want to get this one fixed so any further information will help!

Sorry again for the hassle and thanks for the report.


#34

Hi. Thank you for the reply. I think it happened also when I had just one project open but I will keep attention in future and try to collect such details and let you know.


#35

hi there,

i also have similar issue, also within one project. when i copy some controls (including some symbols) from one mockup to another, i get this notification:

and then when i choose “skip”, i have a duplicated symbol library.
what is also strange, sometimes libraries are duplicated, and sometimes not, even within a same project.


#36

Seems like this problem is bigger than we initial thought.

We will get it fixed!

Edit: Just to verify, @aledis and @Liubi, you guys are on 3.3.6?


#37

hi @Brendan,
I’m on 3.3.3, will try to update today (have to call our support for the admit rights)


#38

Sounds good @Liubi. I’m hoping that solves the issue for you.

There was a nasty copy/paste bug in 3.3.3 that we fixed in 3.3.6. I’m really sorry for any issues it has caused you.

There is still a bug with multiple mockups open, but 3.3.6 should solve the single mockup issue. Let us know if you continue to see it.


#39

@Brendan,
I’ll try to test it next week with the latest version and let you know :slightly_smiling:


#40

Hi there,
I’ve finally installed the latest version and tried to copy some mockups with symbols again. The result is more than interesting, in some projects it works perfectly, in other projects I’m still able to reproduce this issue. Not sure, what it depends on :sweat: