[Bug] Cropping alpha


#1

Bug report #3 this week, someone bring me a drink, please :wink:

Hey guys,

in a related ticket I told you about a problem I had with the not so much centred angle icon. I tried to correct it, but I faced a new problem, while trying to use a workaround.

I noticed, that it is not possible to crop alpha in Balsamiq, tried it first with an icon (take icon, group, use crop), and after that with a this beautiful superman logo.

The result of a crop with alpha is always, that the alpha is turned into white pixels.

Angle Icon

On a related topic: Did you know that when you copy a picture from the web and paste it directly into balsamiq, all alpha pixels turn black? Won’t happen if you save it first and load it from the hard drive. But this one is not such a big issue, since Photoshop has the same problem :smile:

Thanks a lot, kind regards
ArcticMe


#2

Hi again @ArcticMe,

We actually fixed this one in the latest pre-release version too. The fix will be included in the next official release version.

Regarding the other issue mentioned (black pixels when doing copy/paste from the web), we couldn’t reproduce it here. Could you please detail on which we browser and OS you are using? Maybe even share a BMPR file and image URL so we can try to reproduce it? Feel free to share these informations via support@balsamiq.com if that’s easier/better for you.

Thanks for taking the time to report those! :smiley:


#3

Hey Virgin,

thanks a lot. Looking forward to the next update!
Logo.bmpr (3.0 MB)

I searched **logo png **on google, picked the first one (vw logo), hit the copy image button it it and pasted it (ctrl + v) into Balsamiq.

I use Firefox on a Windows 7 PC.

Kind Regards
Dom


#4

Thanks for the details @ArcticMe.

I reproduced and passed it on to the dev team, we’ll look into it!