[BUG] Disappearing objects from mockup


#1

Hey everyone.

I’m working on a Balsamiq project file with 22 mockups (Balsamiq 3.1.8, Windows)

After saving, closing and reopening Balsamiq it seems to change the content of some mockups though.
The mockup previews in the navigator look fine but some mockups are actually missing elements. No custom assets but default Balsamiq elements from the UI library.

After making changes in the affected mockups the navigator gets updated and the object are removed from the preview as well.

I don’t know what happens exactly but … Balsamiq seems to delete random(?) elements in some of my mockups. It happened multiple times now and that’s somewhat … impractical.

Is this a bug only I experience?


#2

Hey @falks,

Sorry for the snag. This sounds like a weird bug.

Would you mind sending your BMPR file to support@balsamiq.com so that we can try to reproduce the issue here? We will keep your data in the strictest confidence and only long enough to try to debug your issue.

Could you specify the affected elements? That will help us track down the bug.

Also, are you saving the file locally or on a network drive?

We’ll get to the bottom of this! :wink:


#3

Hey @Virgin.

Sure, I will send you the file …

Not sure it will only affect those but thus far I experienced problems with the “Comment” and “Button” element.

The file is saved locally.

Thanks for the help :smile:


#4

I’m having the same problem too. mockups create on one machine aren’t portable to another without objects going missing. Tried emailing the files, zipping them, etc. It happens over and over. Bug?


#5

I’m sorry about that @dligon, let’s see if we can figure out what’s up.

Is sharing the file with us possible? As Virgin mentioned, we wouldn’t share it with anyone outside the tech team, and only hold on to it long enough to figure out what’s wrong.

When you get a moment, send an email to support@balsamiq.com, and we will get to the bottom of this.


#6

Have this been solved yet? I am getting the same issue running Win 3.999.499 11/15.2017!


#7

Sorry to hear that, @AJKock. That sounds like a bug that was mainly project-related so we’d love to take a closer look at yours, if that’s ok.

Could you share the related BMPR file and the steps to reproduce the issue via support@balsamiq.com so we can dig deeper? We will keep your data strictly confidential.


#8

@Virgin Email sent.


#9

@Brendan I think I have found what might have caused this. What happens when you have two mockups with the same name inside a project? Can it be that if you delete some stuff on the one, it gets confused with the other one and sometimes deletes it there too?

I’m not even sure why I have two with the same name, but it is quite difficult when you have wireframes with long names and cannot see the end, easily.


#10

Thanks for sharing your thoughts, @AJKock, but each wireframe has its own ID. Therefore, deleting controls/elements in one cannot delete those in another, even if they have the same name (just checked).

Please let us know if this one shows up again. Last steps performed may help to reproduce the bug too.


#11

Darn it. Thought that might be it. The problem happened again :see_no_evil: Will let you know when it happens again.


#12

Any solution to this yet? This issue happens to me regularly and consistently with no rhyme or reason, such that my level of confidence in Balsamiq accurately saving and retaining my designs is incredibly low. Whether closing and re-opening a file or elements disappearing between duplicate mockups or alternate versions of mockups. Not sure what the issue is here, but I have experienced it on multiple occasions (most recently 2 days ago)


#13

Hi @Dan_Belen,

Thanks for the post. I’m sorry about this - it sounds pretty frustrating. Can you first confirm that you’re using the latest version (3.5.15) of Mockups 3. If not, can you download the latest version, install it and let us know if the issue persists: https://balsamiq.com/download/archives/?prefix=mockups-desktop/

Are you saving the project file on your local hard disk or is the drive to which you save an external drive or network drive?

Finally, can you check the local store and let us know if the current version you expect is saved in there: The Local Storage Folder and Backups.

OK, let’s start here and we’ll dig deeper by taking a look at your project file if we need to, ok?