[Bug] Export to PDF not working


#1

3.3.6 first, and now in 3.3.9

the working dialog appears, the bar runs to the end, but dialog doesn’t dismiss and pdf not created on disk. Tried eliminating all options in the pring dialog, removing the last mockup. Only 11 mockup windows, none of any complexity. Thoughts?


#2

Very strange @jalpher, I’m really sorry about that.

Would it be possible to share your project file with us to see if we can figure out what’s going on? If your comfortable with that, you can send it to support@balsamiq.com. We will jump on it as soon as we see it :).

To start with the easy stuff: What OS are you using?

Windows 10, if not kept up to date, gets grumpy when dealing with Adobe Air. We have seen a couple patches that break Adobe Air functions, only to be quickly patched a few days later.

Also, if you are on Windows, would you mind heading over to https://get.adobe.com/air/ and grabbing the newest version - just to be sure we are up-to-date?

I’m sorry again for the trouble. We will do our best to figure out what is up.


#3

I have the same issue. Print dialog gets through configuration, but once I hit save, the progress bars and page progress do not appear. Just goes silent. PDF file never appears. Mac OS 10.11.6 - Balsamiq Mockups 3.5.9


#4

Sorry for the trouble @Squirrel, definitely a weird one!

I’ve just checked and the PDF export seems to work fine for me using Mac OS 10.12.4.

Would it be possible to send us your BMPR file so that we can try to reproduce the issue here? We will keep your data strictly confidential and only long enough to try to debug your issue.

We’ll do our best to help!


#5

Hi Virgin -

I don’t think there’s anything wrong with the file. It has worked sporadically. I am thinking it environment. I work on a corporate network with Digital Guardian on it and what is “accessible” by my OS is not clear.

I am wondering what resources Balsamiq Utilizes to output PDFs? It might be a postscript printer driver or something? If I can pinpoint that - I can ask for admin rights or access to it.

Thanks!

Don


#6

We got the file, @Squirrel, thank you!

I can confirm that it exports on my machine just fine, so I would be your suspicion is correct.

I’ve looped @Florian_Brauer in on the case, and we will hopefully have some more news for you as soon Florian is back in the office. He is in Germany, so it won’t be until the morning that I hear anything.

As soon as we hear something, though, we will update you! In the interim, if you need a copy of the PDF, let me know. Happy to export the file as often as you need until this issue is resolved. :slight_smile:


#7

I have the same problem since a couple of versions.
Just updated to 3.5.14 (OS X) and PDF and PNG Export is still not working.
In previous versions the was a “save as” popup but now it does not show up anymore.


#8

So sorry about that, @raymundfischer!

I assume that this happens in any project, even a newly created one?
Also, are you on the latest OS (10.12.5)?

Could you please reply directly to support@balsamiq.com?
It would be easier to exchange information there and loop in our developer in testing, Florian.

We’ll do our best to help with this.