Bug? License error displayed and comment author not displayed as full name but user id


#1

Since a few weeks we use Balsamiq mockup JIRA plugin with JIRA 6. Before we were on JIRA 5 where we never experienced this behaviour.

In detail:
We are JIRA 6.4.9 and Balsamiq 2.2.26 now.

Only users with uppercase used ids are affected. Users with lower case user ids do not notice any of the following flaws.

We do not see functional restrictions in the mockup editor itself

Yet we noticed the following:

  • The mockup editor shows the following error message on the bottom of the screen (all the time):
    "EULA Violation: This
    version of Mockups for JIRA is more recent than what your license allows.
    Contact your JIRA administrators so that they can purchase a maintenance license
    and make this annoying message disappear. "
  • When a comment is created by the Mockup plugin the comment author is displayed with it’s uppercase user id when you look at the issue in JIRA.It looks like the comment author cannot be resolved

I am pretty sure this is a bug in Balsamiq plugin since i have noticed similar problems when i upgraded my plugins to make them run with JIRA 6. To me it seems the plugin uses one of the deprecated CommentManager.create methods like
public Comment create(Issue issue, String author, String body, String groupLevel, Long roleLevelId, boolean dispatchEvent);

which accept the comment author as String instead of an ApplicationUser object.

If the string passed to author is not lowercased the behaviour is as noticed.

I hope some developer can comment on this. :blush:

The problem should be fixed ASAP since we have many users with upper case user ids and i am not sure if this causes subsequent errors in JIRA itself. Also it looks like our users with upper case user ids have no license which is not true.


#2

Hi Dieter!

So sorry about that weird behavior with commenting! We are going to have our developer Sax have a look as soon as he is able, but in the meantime, I’d like to check your license to see if there is some kind of issue with it.

Do you mind emailing your current License Information to us at sales@balsamiq.com, and if possible, please send us a screenshot of the registration page for the plugin. Here is where you can find that registration screen:
http://support.balsamiq.com/customer/portal/articles/113844#register

I’ll keep an eye out for your email! And I hope we can sort our this mystery for you quickly!
Natalie


#3

Hi Natalie

Thanks for your quick response. Indeed the plugin configuration page tells me that our support period ended on the 15th of May!
So i think the version 2.2.26 was released after that date, right?
I just don’t understand how i was able to upgrade to an unsupported version!!! also don’t understand why this message is not displayed when I create mockups. I am JIRA administrator and have a lower case user name…
Tomorrow i will check with my colleague if we just forgot to install a new license key.
Regards,
Dieter


#4

Well, Dieter, maybe we are one step closer to solving this mystery! I don’t think the comment author issue is related, but I’ll make sure my teammate sees this as well. It is very strange if you aren’t seeing the EULA warning message!

It does seem that the EULA note is coming up because the version 2.2.26 was issued July 16, 2015, and it sounds like your maintenance ended in May. For Atlassian Server customers, we allow customers to install newer versions at any time, but I believe the warning should have come up at the time of the update in the registration screen. All editors should also see a warning at the bottom of the editor which would look like this: https://www.evernote.com/shard/s572/sh/275085a9-b0bd-4c62-a813-ee9474f96515/d76fc2194ed58a98d82997d5332d4772

The older version 2.2.25 which your currently installed license would work with should still be compatible with JIRA 6.4.9: https://marketplace.atlassian.com/plugins/com.balsamiq.jira.plugins.mockups/versions

However, I’m happy to review your license history and see if the license was renewed and just not registered. It may also be helpful for us to see your team’s license in solving the commenting mystery, so do pass that information along when it is available. For privacy reasons, we don’t deal with licenses in this forum, so you can just send a separate email for that to sales@balsamiq.com

Hopefully we can sort it out quickly!
Natalie


#5

Hi Natalie,
I’m sorry i see the error message too now. It was hidden by the windows task bar
Regards,
Dieter


#6

Hi Natalie,
We got response from sales and currently are checking why the renewal fee was not yet paid to Balsamiq. We have an intermediate JIRA partner who buys our licenses. I’ll give you feedback.
Yet the technical problem still persists in my opinion.
Regards,
Dieter


#7

Hi Dieter,
Sorry again for the snag, I have tried to replicate the issue concerning usernames containing upper case.

Here it is what is the result of my test:

  1. it is true that the username containing upper case is not correctly resolved:

  1. however, the presence or not of the upper case in the username seems to not affect the addon license check (i.e. the EULA warning appear in both case).

Once we have solved the license maintenance issue with the help of Natalie, if the license problem still persist, we can have a close look maybe organizing a video call.

PS About the uppercase username resolution, we will fix it in our upcoming release. Thanks for the report!


#8

Hi Salvatore,

Thanks for your feedback.

The license issue has been resolved today :grinning:
Our service partner had ordered the license via Atlassian and not as in the past at Balsamiq. And we didn’t see the license in my.atlassian.com. So this is resolved, sorry for chasing you up because of this.

So i’ll wait for the next release. Any idea when we can expect this?

Regards,
Dieter


#9

Hi Dieter,
Glad that you are on track again :smile:

At the moment we are adding some functionalities that will help the interaction of the JIRA plugin with our other products running the new Balsamiq 3 editor (i.e. Desktop and Google Drive add-on).

No ETA yet, but let’s say we plan to release in the next weeks.

Cheers