[BUG] Mockup 3 Desktop constantly crashes!


Hi there,

I have been using Mockup 3 at work now for about a month and am really coming round to liking it apart from one thing, the crashes!!

So this has happened with files that are stored on our companies network and also on my local laptops C drive. I am using Mockup 3 to storyboard some new lessons for some courseware I am updating. So there can be a lot of mockups in the project (100+).

Now the crashing seems to happen randomly, I can be opening a file, opening another file when one file is open, deleting things, importing an asset etc. I luckily have it set to save as changes happen so I don’t loose much when this happens but it is very frustrating!

I really would love to encourage the rest of my colleagues to use this software for storyboard development but this issue is stopping me from doing this.

I really hope there is a fix for this.

Kind regards,



Oh wow, I’m really sorry about that Kelly. That sounds insanely frustrating. :frowning:

Let’s try deleting the MockupsSettings.db file in your local storage folder. Hopefully, that solves the problem. But, if not, we will dig deeper!


Hi Brendan,

Wow thanks for the super quick reply, impressed! :grinning:

I actually just renamed that file and put OLD at the end and have restated Mockup 3 and will see how things go tomorrow at work.

Thanks for the advice!

Kind regards,



HI again!

So I have been using Balsamiq quite a bit recently and I am less than impressed! I am working over a network with large Balsamiq file sizes so not sure if this is causing a problem.

I get constant crashes while trying to work on these files, I am going to try working locally with them but I am not sure that is going to help.

But I have now had Balsamiq crash and I then force close it using Windows Task Manager and this seems to delete the Balsamiq file!! To get the file back I have to use our network back to get to an earlier version of the file and usually loosing work I have done.

This is unacceptable and a real shame as I do like this piece of software. I have tried doing the fix suggested by Brendan and while it seems to work for a while, I always end up getting constant crashes. And this crashing and deleting of the Balsamiq file is the last straw!



Ugh, what a drag, Kelly. I’m sorry about that.

It sounds to me like the large file + network connection are causing the issue here. Luckily, there is are backups in that localstore folder that should have a copy of the file you’re working on.

While I think working locally will help, let’s try disabling autosave and see if that stops the crashes.

What I think is happening is that the app is trying to autosave, but may be running into issues with the networked drive. Disabling that should help.

Give it a shot and let us know.


Well I have tried working off of my C drive and also disabling the Auto save feature and still no luck.

I have come to the conclusion that this software does not support large numbers of mockups and graphics. It is a shame as I was going to recommend my colleagues also use this software, but it is so buggy and crashes so much I really can’t recommend using it.

I really hope your new release improves things massively as not being able to use it on a network and constant crashes means this software is of no use to our way of working.


I’m sorry about that, Kelly, but I totally understand.

Obviously, we wish you had had a more typical experience with the software, but there is something gumming up the works here.

If you send us your project file, we may be able to take a look and see if we can figure out what’s going on, but I know that’s a big ask.

All to say, I’m sorry it’s not been smooth for you, Kelly. If there is anything we can do to help right now, please let me know.