[Bug] Mockups 3 crashes every time I put macbook to sleep


#1

Hi. I’m running Mockups 3.1.8 on OS X Yosemite 10.10.5. Mockups 3 crashes EVERY time I put the computer to sleep and turn it back on again. This is not really acceptable. I wrote about it before and thought it might be a problem with the fact that Mockups was not updated from version 3.1.2 and neither was my system. They are up to date now. Same problem. Again… it happens EVERY time. You’re fixing this embarrassing bug and going to releasing an update really soon, right? :neutral_face:


#2

Hi @Smaranda_Calin,

Sorry again for the frustration this bug is causing you. :confused:

I am unable to reproduce the bug with the exact same configuration you are using.
I passed it on to the dev team, they will look at it (thanks for the detailed information).

Meanwhile, this page could be helpful: http://support.balsamiq.com/customer/portal/articles/222853-what-should-i-do-if-mockups-crashes-for-me-


#3

Updated Adobe Air. No effect. Just happened again. :frowning:


#4

I had a look at the link. How do I know if I should file a report to Adobe rgd. Air as well?


#5

If you need more information about my system, I’m happy to send that to you privately.


#6

Thanks again for the detailed informations. We’re aware of the bug and we are working on a fix. It is related to the bundled version of Adobe Air.

Sorry again for the frustration with this. I’ll let you know as soon as I have more informations to share.


#7

I’m seeing the same exact issue. I"m also using Mockup3 on MBP. Anytime my laptop comes out from sleep, I can see Mockup 3 already crashed. While I’m happy that I have never lost data, it is not a good feeling at all.

people normally put in hours to come up with mockup, and losing them is like losing an account. Please fix this ASAP !


#8

I’m sorry about that @Tejas_Shah, I know it’s an annoying bug.

Are you disconnecting from a monitor after you put your macbook to sleep? That’s a crash we are all sufferers of, but can’t do anything about because it’s a bug in Adobe Air (the platform that Mockups runs on top of.)

We want to get this fixed, but are at the mercy of Adobe right now. I’m really sorry about that. I know how frustrating it is :person_frowning:


#9

I can confirm this happening too. Every time I disconnect monitors to move location and close the lid Balsamiq 3 crashes. This doesn’t happen with Balsamiq 1.


#10

Any update ? It’s annoying :slight_smile:


#11

So sorry for the trouble @psc, this one is very annoying indeed.

While we don’t had an immediate fix for this one (since it is caused by using Adobe AIR alongside), we’re working hard on the next major version of our product and it will be native! We hope to have this one fixed there.

No ETA yet but we’ll keep you all in the loop here as soon as we release it.


#12

Hi. I’m running Mockups 3.5.6 on Win 10, Version 1607, OS Build 14393.693, I was having the same issue with 3.5.5, putting the computer in sleep mode, on wake-up Mockups will ask me to save the Project every 20 to 30 seconds. I saved the Project as a new name and closed & reopened Mockups but 9+ hours worth of work was gone, the auto save was not saving, my new Project file name was not present anywhere on the computer. Very frusatinging to say the least. Yesterday I upgraded to 3.5.6 :unamused:


#13

So sorry to hear that, @DonO. :disappointed:

Have you tried to check in your local store folder for this file?
The folder to look for is called LocalProjects, as detailed here.

Hopefully, it will have a recent version of your file but if not, please email us and we’ll dig deeper!


#14

Excellent, thank you Virgin, I found what I needed, much appreciated!

Don


#15

Similar deal - on Mac, if I disconnect from my monitor, balsamiq crashes. Brendan is this the same issue that you were referring to back on 10/15? Is it supposed to be fixed OR is still an issue?


#16

I haven’t personally experienced this issue since the 3.5.1 update, @Raj, but I think the triggers are still there, unfortunately. :frowning:

Once we ditch Adobe Air, we will ditch this bug for good. :slight_smile:


#17

wow your handling of this bug is truly awful! this is still happening in Feb 2018


#18

So sorry to hear that this one still affects you, @vsethi.

The good news is that we are getting closer to our new native Desktop version (hopefully this year).

In the meantime, you may want to try out Balsamiq Cloud, our new web version. It features the new and native editor that will be used in the upcoming Desktop version.

We’re getting there!


#19

I found this thread after experiencing this issue myself, and wanted to share the solution that has worked for me:

I noticed that the version of Adobe Air bundled in ‘Balsamiq Mockups 3.app’ was several years old. As an experiment, I downloaded the latest Adobe Air installer from https://get.adobe.com/air and replaced the ‘Adobe AIR.framework’ directory in ‘Balsamiq Mockups 3.app/Contents/Frameworks’ with the version extracted from Adobe’s installer.

You can access the contents of these packages from the console, or by right-clicking them in Finder, then clicking ‘Show Package Contents’.

Be sure to exit Balsamiq Mockups before doing this.

This appears to have resolved the crash on sleep issues for me. And I haven’t noticed any other issues with the app yet, though YMMV.


Current Release of Mockups 3 for Desktop: 3.5.16
#20

Thanks for sharing this, @tristan. I’ll let the team know and see if we can improve it on our end.