Bug Report: Saving Issues


#1

Hi there, I’ve noticed a reoccurring bug that seems to only affect the Windows version of the software. It could be an issue with AIR but it’s worth bringing this to your attention. Sometimes Balsamiq is refusing to overwrite image files in Windows 10. I believe this was also happening in Windows 8.1 which is why I believe it could be an issue with AIR.

When saving a mockup, I confirm the overwrite but absolutely nothing changes to the actual image file. I get a confirmation in Balsamiq that the overwrite was successful but viewing the image confirms that this is not the case. A workaround to this is to name the file something different but obviously this is less than ideal for quick changes to existing files.

This issue only occurs in Balsamiq, overwriting files is not an issue in any other program. This issue is not solved by running Balsamiq as Administrator and the issue does not apply to bmpr files, only exported images that overwrite existing ones. When sorting files using Explorer, I can see that the date modified is not updating for the image, the save is not occurring at all despite receiving the confirmation popup and no errors.

Version info:
Version: 3.1.3 - 06/23/2015 10:16
Adobe Air Player Version: WIN 19,0,0,169

I realise that I’m running a slightly older version of mockups (automatic updates would be a fantastic addition, by the way), is this a known issue with 3.1.3? I’ll try updating and see if the problem persists.

Edit: I’ve checked 3.1.9 and the issue is still persisting.


#2

Hey @mekeirc, thanks so much for taking the time to write a detailed bug report! I’ve been trying to reproduce the issue on my end, but haven’t been able to yet. I’m on Windows 10 with the same air version as you, so something definitely is weird.

When you get a moment, would you shoot us an email at support@balsamiq.com? This is a bug we’d love to get fixed!


#3

Right, I’ll be keeping a note of this issue during the week, it certainly is a strange one.
It could be a number of things, but the fact that the issue is limited to only Balsamiq indicates that it probably isn’t a disk issue (I’ve recently updated the SSD firmware just in case). I’ll try some different AIR-driven apps to see if I can replicate it.


#4

Sounds good, keep us updated.

To be sure I’m following the correct steps:

  1. I’m opening a mockup
  2. I’m exporting it to PNG
  3. I’m making a change to the mockup
  4. I’m exporting it to PNG with the same name, overwriting the first PNG

In your scenario, the PNG never gets overwritten. That sound right? I have tried it exporting both the current mockup, and all the mockups.


#5

Yes, that is correct.
It isn’t consistently broken either, which is more of an issue. It’s limited to the BMPR I’m using but not others, I would send you a copy of the file but I’m quite sure that would break my non-disclosure agreement. It happens from time to time and causes great frustration.


#6

I’m really sorry about that @mekeirc, the last thing we want to do is cause you frustration.

Talking to the team, it seems like this problem has come up once before (with a super complex project), so it’s an elusive bug, but a bug we have seen (you are not alone!) There are a couple things we should poke at and see if maybe they aren’t the cause.

When you have a moment (and you notice that it has happened) can you check the RAM usage of Mockups? (It would be in the Task Manager.) Also, (a shot in the dark) is there a chance that the file is being locked by another application when Mockups tries to overwrite it?

Thanks again for helping us track this weird bug down.


#7

There’s nothing particularly strange about the RAM usage, sitting at around 200MB idle. The RAM usage doesn’t spike.
The file isn’t open in anything else.

Although I believe the wireframe file in question wasn’t created in an older version of Balsamiq, some of the original bmml files were consolidated into bmpr’s at some point, I can’t rule out the possibility of old elements from a bmml making their way into newer bmpr’s. Again it’s a shot in the dark, but something worth testing.

Thank you for your ongoing support.

Edit: I’ve managed to replicate it in an entirely different bmpr. Dragging individual mockups into a new one seemed to give me the same saving issue, perhaps this is related.


#8

I am experiencing similar behavior as the original post. I’ve noticed it specifically with layers/z-order. If I reorder layers then “save” which prompts the autosave message to show, I can export to PDF and the layer order has not changed. If I make the change, “save”, then reopen the file the layer order has not changed.

I’m so far along in this particular mockup I cannot be sure when it started happening. In my case the issue is evident when using a locked modal layer.

Balsamiq Mockups
Version: 3.3.12 - 033/16/2016 04:16
Adobe Air Player Version: MAC 11,9,900,169


#9

Hi @strahan,

Sorry for the snag! I’ve just tried to reproduce this but it works as expected on my end.

Would it be possible for you to send the project/BMPR file to support@balsamiq.com so that we can try to reproduce the issue here? We will of course keep your data in the strictest confidence and only long enough to try to debug your issue.

Thanks for the report, we’d like to do everything we can to get this fixed!