Balsamiq Community Discussion

Bug: Sometimes Cannot Save Mockup


Occasionally Balsamiq refuses to save. You select “Save As” and the title bar changes, but the document does not appear in the destination. And attempting to quit gives the warning that there is unsaved data. Choosing Save at this point does not work and the program won’t close.

When I had this problem the only way to close was to force the program to close and the document never appeared. My coworker was able to select “don’t save” to close to program yesterday and the document did appear in the destination once Balsamiq closed, but I’m not sure if the document was correctly save - she didn’t check.

Restarting the Balsamiq fixes this and allows you to save normally again. I doubt this is a reproducible bug, but once it happened to my coworker I figured you might want to keep an eye out for what this bug might be and it wasn’t just my system acting up.

I’ve updated to the newest build and I’ll see if it happens again.

Edit: I just realized that perhaps I shoudl be putting this in the B3 Beta Category, but that’s not an option in the dropdown, just Mockups 3…?

Balsamiq 3 sometimes won't open after it freezes and I force quit the application

Hey @RaeHanley, thank you so much for letting us know about this. And for doing so calmly! :slight_smile:

This is something that we’ve heard before and are tracking down right now. We think we are close to having a fix ready. Sorry for the trouble. Maybe check back early next week and see if we are past 3.0.3. Thanks so much!


I had the same issue but it was surrounding bringing in a file from the previous version and trying to save that. Would not save, but when I shut the program down my “saves” were there. But they wouldn’t open - got an error message.


I’ve had the same issue, also after importing mockups from a previous version. After finally quitting without trying to save the project again, files did show up (several versions), but all are missing symbols, and most of the newly created mockups, though interestingly, they have edits made after those new pages were added. But a whole group of pages that were imported but not edited are not there at all.

I exported to PDF for my client and exported to BMMLs when I was unable to Save. I was then able to create a new project and import those BMMLs to restore everything.

But, I find I cannot save this Project either. This time, instead of trying many times, I quit after the first try. The bmpr file is there, and opening it does restore the pages, though not in the same order. It also has defaulted to the name of New Balsamiq Project 1.

If I create a new project from scratch, I don’t get the error. Created a new project and created a symbol and don’t get the error.

Hope those clues help. As a workaround, I’m exporting to BMML before closing the file, and importing that into a new file when I begin again, then reorganizing the order of the mockups.


Ha! You all are the best. Thank you so much for taking the time to test this out with us and for sharing your results.

We think we have a lead here. We only have one file that someone has sent to us at that consistently reproduces the issue. It is a zip file of a project created in 2.2. We found that this zip file contains an assets folder named “Assets” instead of “assets” which caused a couple interesting problems.

If you imported the zip file directly into B3, the actual assets were not imported at all—images, symbols, icons were ignored. Unfortunately, trying to support that would made the import even riskier. So we are going to probably just document that you have to make sure that your ‘assets’ folder is named exactly that.

If the folder was not compressed, and imported as a BMMLs folder, then we saw the problem where you could not save.

The workaround was simple though. If we renamed the “Assets” folder to “assets” and then made a new B3 project and imported again, it worked fine. :smile:

Also, if you used the pre-release version (, importing the folder worked fine. The ZIP import still failed to import symbols and images, but importing the folder worked fine.

We will be really interested to know how this lines up with what you are seeing. Thanks again!

Can't save imported project in Mockups 3.0.3


That helped. I made sure to import the BMML zip (which had the assets named correctly) into my new project, then saved it immediately. Saw the file appear. Closed it, reopened, reorganized the mockups, saved, closed, reopened, and the order was maintained.

FWIW, my v2 files did not have assets, but I did find a stray PDF in the folder from which I imported the v2 files.

You just turned a frustrated beer into a celebratory beer!



We fixed some issues related to saving in 3.0.4.
Here are the complete release notes:

As usual you can get the new version here:

Please let us know if you keep on running into issues.


I unfortunately seem to be seeing something very similar using 3.1.2 - I posted about it in Balsamiq 3 sometimes won't open after it freezes and I force quit the application


I am having the exact same issue as reported above. Won’t save. I attempt to save anywhere to no avail. When I try to close, I get the standard message stating that I didn’t save. Not fun. Please fix.


Hi @Amanda,

Sorry you’ve hit this snag!

Could you please check on the version of Mockups 3 for desktop you are running? If not the latest (3.2.4), please download it from this link as it may help:

Please send a mail to if the issue persists, we’ll dig deeper!


I was having this same issue in 3.1.2 today. One of my assets was marked “file not found”. I tried to delete (move to trash) and the project still would not save. I then emptied the trash and the project would save.


Hi @Kevin_Walker,

Sorry for the snag! I’m glad to hear that you were able to fix it.

I would recommend updating to our latest version (3.3.12), available here. We recently implemented a bunch of new features but most importantly a new backup system to help with such issues.

Please let us know if you need anything else, we’ll be here to help! :slight_smile: