[Bug]Unable to write an underscore in Balsamiq with a French BÉPO keyboard


#1

Hello Balsamiq team,

I’m using Balsamiq Desktop (latest version) on macOS Sierra with a French BÉPO keyboard.
With this keyboard, writing an underscore requires to type Alt + Spacebar. This works perfectly on any app but Balsamiq… Instead I see spaces displayed in Balsamiq.

I know I have a very special configuration, but I guess any keyboard configuration should work with balsamiq so you might have a bug there. :slight_smile:

Let me know if you need more details, I would be happy to help.


#2

Hi @AToyane,

Sorry for the hassle today.

Unfortunately, I don’t have the specific keyboard in hand to try to reproduce this one.
Did this use to work in the previous Mac OS version? Or in previous Mockups versions?

We’ll fo our best to help with this!


#3

Hi @Virgin

No problem. I am using a classic French AZERTY keyboard with a different mapping (software keyboard layout).
The keyboard layout can be downloaded here. Then you need to move the fr-dvorak-bepo.bundle file to /Users/yourUsername/Library/Keyboard Layouts
And finally change your keyboard preferences to use Dvorak Français.

I’m pretty sure the problem was already there with the previous Mac OS version and the previous Mockups version. I don’t think it’s a new problem, I might be the only BÉPO balsamiq user :slight_smile:


#4

Thanks for sharing the details, @AToyane.

I was able to reproduce it (I also use a French AZERTY keyboard) and passed it on to the dev team to see if we can do anything about it. I see that some native Mac apps seem to have trouble using that mapping too (e.g. Notes).

I’ll keep you in the loop! :slight_smile:


#5

It’s great to see you managed to reproduce the issue!
My native Notes app works fine here, weird.

Thank you for your help Virgin