[BUG] Zoom All to Fit


#1

I am using the latest production version (3.2.2) and trying out some of the new features. I have found the Zoom All to Fit is not consistently working. To test I zoomed in on some mockups, zoomed out on others, and left some zoomed in to fit. Within a single project I am seeing that sometimes it sets all the mockups to zoom to fit, but other times it only sets the zoom to fit for some of the mockups.

I also am having problems activating this feature using the keyboard shortcut. I thought it might be another program using this key combination as a hotkey, but I ended all but our antivirus and malware protection software (can’t end due to network restrictions) and still cannot activate this feature using Ctrl+Shift+0.

If it would help, I could send you a copy of my project.

Version: 3.2.2 - 10/01/2015 14:24
Adobe Air Player Version: WIN 19,0,0,169
Windows 7 Enterprise 64-bit

-Russ


#2

Hey @russ, nice to see you again. I’m sorry it’s not under better circumstances.

I think you may have stumbled on a couple bugs we have been tracking since yesterday.

2nd bug first: The Windows shortcut. It seems like Windows captures CTRL+SHIFT+0, though it doesn’t seem to do anything with it. In Vista, that shortcut would change the input language (https://support.microsoft.com/en-us/kb/967893) but it’s unclear if it still does. Nevertheless, it steals the shortcut before Mockups even gets a look at it. We are working out a way to fix that.

As for zoom to fit, we found a bug where it doesn’t zoom alternate versions of Mockups. Is that the inconsistency you are running into? If not, shoot us an email at support@balsamiq.com with your project file (thanks for offering that - it always helps!) and anything you can think of that may have lead to the inconsistency (zooming from a particular mockup, changing program focus, things like that - it’s totally ok if you can’t think of anything.)

Thanks Russ. I’ll be standing by for your reply :smiley:


#3

@Brendan no worries about the issues. I’ve been in the software industry for years – sometimes no matter how much you test, there are some scenarios that slip through the cracks. I also did software support and analysis for years and truly appreciate how much you guys care about these issues and care about making the software better and better with each iteration. Keep up the good work!

I double-checked and I am not using any alternate versions in my project. I will send over a copy of my project file via email.


#4

So the good (bad?) news is I was able to reproduce the bug pretty reliably. We will get it fixed!


#5

Woohoo! :smiley: It’s not pebkac-related error. That always makes me feel better.

Thanks for the superb customer service! I’ll keep my eye out for the fix.


#6

Hi,

I installed 3.3.3 just recently and I found the Zoom All to Fit and Zoom All to 100 % ist not working correctly anymore. It seemed to be fine in the previous version, though.

When I use CTRL+SHIFT+0, the currently selected mockup is zoomed correctly, but the next one with the same size is not. When you page on, a mockup with a different size is now zoomed correctly, but the one after it (same size) is not.

Also, when using CTRL+0 and CTRL+1 in succession, the mockup is not panned correctly anymore, the top left is scrolled off screen. This also used to work.

Cheers,

Philipp


#7

:person_frowning:

I’m seeing the bug on mockups with symbols, does that sound right to you @PhilippQF?

I’ve filed the symbols bug. We are still testing to see if we can trigger it in other scenarios.

When it comes to going between zoom to fit and actual size, are controls being scrolled off the screen? I’m seeing the canvas panning, but it looks like it’s centering so the left most control is in the upper left corner of the view.

Is that what you’re seeing? Let me know if not. We want to get that fixed too!


#8

Brendan,
I am still seeing Zoom all to fit problem too. However, I have not figured out what the pattern is. Nearly all of my mockups have symbols on them, but some work and others don’t. I will forward you a copy of my bmpr file.

I think Air is freaking out too. I was able to run the zoom all to fit function once, then tried again and nothing happened. I used both the keyboard shortcut and menu option. Restarting the application seemed the only way to get it to work again.


#9

I think it’s when we try to zoom to fit a mockup with a symbol that we haven’t drawn yet. Symbols don’t get loaded until you visit the mockup, so the zoom to fit is zooming to fit without having the symbols loaded.

At least, in my testing that is what I have found. Thanks for sending me your project, Russ. I will see if my theory holds true with your project.

Either way, thank you guys for helping us with this stuff!


#10

Hi @Brendan,

yes, I am using symbols, so that fits.

I found that after zoom to fit, zoom to acutal size is centering on the selected element.

You said that symbols are drawn at a different time than the other elements. There is another issue in 3.3.3 which might be connected with this: In thumbnail view (both in the Navigator and the Thumbnail Grid), symbols are sometimes not rendered. I have not found a way to make balsamiq do that, even selecting the symbol in the mockup does not bring it up in the thumbnail. You only see the square with the X.

Cheers,

Philipp


#11

Hi there,

I also have this problem, and it’s also hard for me to find it out, when zoom all to fit works and when not.
The only thing I’ve noticed is that it sometimes doesn’t work when I work with two screens and when the resolution of those screens are different. When I use this feature for the first time, it works, then I drag a window to another screen with another resolution and try to use this feature again, and then only a current Mockup is zoomed.


#12

I am using multiple screens with different resolutions as well. It used to work in previous 3.x versions, but it doesn’t now.


#13

Thanks for the additional information @Liubi and @PhilippQF.

We will make this silly thing work, it may just take some time. Your help continues to be awesome :slight_smile:


#14

Hi all,

We just released our latest official version (3.3.9) including the fix for this one. Zoom all to fit should now work as expected.

Thanks again for the reports and help! :slightly_smiling:
As always, please let us know if you are still seeing any issues.

You can get the new version (3.3.9) here:
https://balsamiq.com/download

And the complete release notes are here:
https://blogs.balsamiq.com/product/2016/02/09/pcr-ro/


#15

Thanks for the update. I just tested this out with 3.3.9 and the Zoom All to Fit is working correctly with my projects. I tested both the keyboard shortcut as well as the menu option. Thanks!


#16

Hi,

I just wanted to let you know that the keyboard shortcut CTRL+SHIFT+0 is still not working for me.
I’m on windows 7 and followed the instructions in https://support.balsamiq.com/desktop/winshortcuts/. But that didn’t help :disappointed:. I’m using Balsamiq Mockups for Desktop 3.3.12 (due to company policies I cannot download the latest version, so I cannot see wether the problem still persists in 3.4.2)

Kind regards

Ilse


#17

Ugh, I’m sorry about that @Ilse.

Can you verify that neither of these options is set to CTRL+SHIFT?

I’ll see if I can find other places where Windows may hijack the CTRL+SHIFT command. What version of Windows are you running, and what is the default language it is set to?

Sorry about the hassle with this. Let’s see if we can get it fixed for you! :slight_smile:


#18

Hi Brendan

Thanks for your quick response!

Neither Switch Input Language nor Switch Keyboard Layout are set to CTRL+SHIFT:

I’m running:

And the default language = Dutch (Belgium)


#19

Thanks for following up, @Ilse!

@russ let me know that he had a similar problem, but if he selected something, and then select Not Assigned again, it worked.

Would you mind giving that a shot real quick, just to see if it solves the problem?


#20

Hi @Brendan

I tried selecting almost every combination, even rebooted in between (although I think that’s not necessary), tried another keyboard, tried it on my colleagues’ computer and even tried changing the language to English (US), but still not working :disappointed: