Can not load images into mockups


#1

Hey,

I am using Mockups for Confluence and wanted to import my Mockups from mybalsamiq into our confluence. That works pretty nice, but as I have some Images in my mockups, that do not get imported as well (Image not found) I tried loading them into the balsamiq editor within confluence like I did in mybalsamiq. When I attach the images I get this:

Resulting Import Error

Sorry for using extern hosting service, I couldnt attache it straight.

I can open and use the files in mybalsamiq no problem.

How can I solve this?


#2

Hi, @pDiem. Because of the way Atlassian Confluence handles attachments, importing a BMML into Confluence only imports the XML for the file, and will not attach assets. To get the images imported, edit the Mockup and then select and edit the image, and use the image dialog to attach the images from your desktop.


#3

Hey Mike,

that is exactly what I am trying to do.

The dialog works fine and I get something uploaded but the uploaded image is still the default “Image not found” preview.
It seems like it does not upload the content of my image.


#4

@pDiem I think I’ll need some exact steps to reproduce the bug you’re seeing, so I’ll reiterate what I tested on my side, that worked so you can compare with what you did and tell me which steps were different from you.

  • In myBalsamiq, create a mockup and add an image
  • Download the Project to Desktop and unzip the project
  • Open the Mockup in Balsamiq Mockups 2.x and select Export Mockup XML
  • Edit Confluence page, select + UI Mockup (using “+” toolbar menu item).
  • Select Import Mockup XML and paste Mockup XML
  • Image displayed as “Image not found”
  • Double click image to import a new image and browse to the image in the downloaded mybalsamiq project’s assets folder.
  • Save

Are these the steps you took?


#5

Hey Mike,

I use mybalsamiq.

  • I create a mockup with an image
  • I go to Project > Export Mockup XML
  • I save the content.
  • I go to Confluence and Edit an existing Page. I use Insert > UI Mockup, the editor opens.
  • I use Import Mockup XML and paste my code in there.
  • Now every Image in my mockup is declared as “Image not found”.
  • I doubleclick the image to load a new source.
  • I use browse to find my file, I press attach

Now this is where the bug is happening. Once I uploaded the new file the thumbnail shows “Image not found” and when I define it as an image source it is just “Image not found”.

I hope that makes things clearer.

Thanks for your help


#6

@pDiem After you import the new image and press attach, did you also select the image from the panel in the bottom half of the image dialog?


#7

The bottom half. The problem is that the images contents is not loaded. The problem only exists with a few images,
I can load those images in mybalsamiq no problem but not in confluence balsamiq UI mockup tool.

I thought that there could be an issue regarding the size of the image, but that does not matter as I tried it with jpgs and pngs of varying sizes.


#8

Ah, I see. Thanks for the added info @pDiem. I’m going to pull in our developers to see if they can help.


#9

Hi @pDiem,
Sorry for the prolonged hussle. The problem could be related to the image filename: does the images non loaded contain special chars in their filename (e.g. &, %, /)?


#10

Yes actually it does contain &. It seems like getting rid of it solved my problem.