Cannot change to a mockup in left hand panel using mouse on Mac


#1

I have encountered a strange and frustrating bug in Balsamiq 3.5.5. (First noticed in 3.5.4.)

I am sometimes unable to change to a different mockup in left hand panel using the mouse on a Mac.

  1. From Mockup 1.
  2. Select Mockup 2 with the mouse in the left hand panel.
  3. Interface does NOT switch to Mockup 2.
  4. Select Mockup 3 with the mouse in the left hand panel.
  5. Interface DOES switch to Mockup 3.
  6. Select Mockup 2 with the mouse in the left hand panel.
  7. Interface DOES switch to Mockup 2 this time. (So there is a workaround but it distracts from just getting things done.)

I recorded an MP4 of this problem but could not attach it to this forum entry.

I’ve also noticed a general slowness in the application of late. Even when there are only a few mockups. (Although I have a large number of assets and symbols.)


#2

Weird that you should mention this, @paulshoughton, as I ran into it today as well. I was using Mockups 3 for Google Drive, however.

If you want to shoot the video over to support@balsamiq.com, I’d love for the dev team to see it.

Have you ever had it happen right away? Or does it usually happen after you have been working for a while?

As for the slowness, that very much could be related to the symbols and assets. If it’s possible, sending us the project file will help us diagnose this a bit better.

All this to say, I’m sorry for the trouble, my friend. Let’s see if we can figure out what’s going on. :slight_smile:


#3

Thank you for the speedy response. I have emailed the video and the bmpr to your support email.


#4

Got it, Paul. Thanks!

Looking into it now. :slight_smile:


#5

Hi Paul & Brendan,

I am not sure, if it is good practice to resurrect a thread from 2 months back. But I’ll do it anyway, since it seems no final comment was posted on it. Rather than post a new topic, I’ll continue here.

Today while working with 3.5.5 on a Windows machine, I stumbled across something that sounded very similar to what the OP describes. The way it showed up for me, is that when working on a BMPR with say 5-6 mockups, I would be working on the item say 4th from the top. I would want to switch to number 5 (which is the one directly below item 4). Clicking item 5 would not cause any reaction. Waiting and clicking again, no reaction. I could go to any other item (3 or 6) and THEN go to 5, and the mockup would switch to the correct one. But it would seem that sometimes, somewhere something got locked up so I could not browse to the “immediate next” mockup in the left hand pane.

When this issue showed up, I had opened a somewhat larger project in one window, then opened a second Balsamiq “instance” and was copying some stuff to the new project.

My $0.02 cents - I can’t seem to reproduce this situation any longer. Maybe the case is already closed and I’m just stirring up old stuff… :confused:

Best regards,

// Magnus


#6

Hey again @BLB. :slight_smile:

I think the reason that we didn’t post a followup here was that we, like you, didn’t land on a surefire cause for this.

Paul and I speculated that it might be from the fact that he rarely closed Mockups 3 for Desktop, and often had multiple files open at one time. This can cause instability in the app after a while because Adobe Air will get grumpy. When Adobe Air gets grumpy, weird things happen.

This is something that will be better with the native version of the app - something we will be talking about more soon!

Sorry again for the trouble, Magnus. Let me know if you see it again.


#7

Doesn’t everyone do this? :wink:


#8

I haven’t seen the problem recently but I also haven’t been working with large sets of mockups for prolonged periods. (I’ll monitor things when my design workload ramps up again.) Thanks.


#9

It just happened again for me.

I was working with only one Balsamiq Mockups 3.5.5 window open (Windows 7 machine). The project I started working on had originally 14 mockups, then I had added five more so up at 19 now.

When I noticed this selection issue, I was in the process of copying buttons from one mockup to another. I selected four buttons (all with icons and links assigned, if it matters) in one mockup, Ctrl-C, then started going to each one out of four other mockups. Removed the buttons (without links) from those mockups, then Ctrl-V to paste the right ones in. At some point, the software seems to have glitched.

Now, when I select mockup X in the project, the view switches to that one. But I can’t select the one right below in the mockups list (lets call that Y). If I double-click Y, the “Rename Mockup” dialog shows up but proposes me to change the name of X.

When I select a mockup in the list, and press arrow down to browse, it skips one and selects the mockup that is two steps down in the list.

Is there any debug log that can be sent to support, or is there a “debug option switch” somewhere that can be enabled so I could gather some more data for you to look at?

Br

// Magnus


#10

There is a log file in your local store folder, but I’m not sure it’s listening to the right events to catch this bug.

Would it be possible to share the project file with us? We wouldn’t share it with anyone outside the dev team and would delete it as soon as we are done testing it. I wonder if we would be able to reproduce the error, using your steps.

If you feel comfortable sharing it, the easiest way is to email us. Thanks for keeping us in the loop on this one, Magnus!


#11

Hi Brendan,

Thanks for the reply. I am indeed able to share the project file and just sent it to the support email address, along with a description of what I did to cause the issue to appear (as I recall it).

Br,

// Magnus


#12

Thank you, my friend. I will sick @Florian on it! :slight_smile:


#13

Back using Balsamiq more heavily today - editing 4 files at once, not too many mockups in each but a sizeable set of symbols probably pushes the file size above 2MB in each case. I had probably been going for 3+ hours.

After duplicating a mockup I noticed that the on hover mockup menus stopped working and I was no longer able to drag around the mockups to re-order them.

I chose to quit Balsamiq and then saw an error stating that the application crashed unexpectedly.

Whilst this problem is not quite the same as the one at the start of this thread I though I would raise it here as a starting point. (Since it seems related to instability when Balsamiq is heavily used.)

I have the text from the crash debug detail that I can email through if required.


#14

I’m very sorry about that @paulshoughton. I would bet that it was an Adobe Air related bug. Restarting the app occasionally should really cut those down. It’s one of the many reasons we are pushing very hard towards native (non-Adobe Air based) apps.

Our native web app just started a closed beta, so things are moving along there. The Desktop apps will follow its release - so things will get better. I’m really sorry for the bugs everyone is hitting, though. We will do whatever we can to mitigate those.


#15

FWIW, I’m having the same issue. I thought it might be a bug and made sure I had the latest version of Balsamiq. I do, v3.5.7. Hasn’t solved the problem. :confused:

iMac 2011
OS X 10.11.6
2.7 GHz Intel Core i5
AMD Radeon HD Graphics 6770M 512 MB

One thing I did notice is that the system requirements call for AIR SDK Development, but I have Adobe Air Player. Could that be causing problems?


#16

Shouldn’t be an issue, @br0nw3n. We bundle Air inside the app itself, so you don’t need to install it.

Are you running 3.5.7?


#17

Hi @Brendan. Yep. I even said so in my comment. :wink:

The problem seems intermittent. I’m still trying to figure out what the trigger is, but I haven’t been able to so far. It does seem to happen after the app has been open for a while, so I don’t know if it’s a memory leak issue.

Like I said, I’ll keep trying to figure out how to duplicate the issue.

FYI, the problem was present in v 3.5.5 and 3.5.7.


#18

Yeah, I would bet it’s a memory leak, especially if restarting the app solves the problem.

We know it’s a bug in the Adobe Air framework, but we just aren’t sure where it is. We have been tracking it for a while.

It won’t be a problem forever, though! The native app is coming along :).