Balsamiq Community Discussion

Cannot save, cannot save as, cannot export, and cannot cancel

This is a deal killer of a problem.
I cannot save a project.
I cannot save as a project.
I cannot export the project to PDF.

When I invoke these operations (above) the save dialog appears, I enter the information, and the dialog grays out and sits there without saving or exporting.
After a few minutes, the dialog un-grays and I try to save/export/save as again.
Same result.

I tap on the Cancel button and nothing happens.

I have to Force Quit the application.

Not a good experience and no longer a useful product if this is not resolved.

Hi @chrisc

Thanks for the post - I feel your frustration. I don’t like to assume but can I assume that you’re using Mockups 3 for Desktop on macOS and you’ve recently updated to 10.15.1 (Catalina)?

If not, please let me know which platform you’re on and which OS version you’re using and we’ll continue to work through this.

If you are on Catalina, it’s a bit of a bad news/good news situation.

The bad news is that this is caused by the Catalina upgrade - it’s an issue with the underlying framework we use (Adobe Air).

The good news is that there is a reasonably painless workaround that will allow you to save/export your work.

If you just choose a different folder (e.g. try the default ~/Downloads or ~/Desktop folders), you’ll be able to save and export without issue. The issue seems to impact networked/virtual drives (e.g. Dropbox or Google Drive) so I’d advise avoiding those when saving directly (you could still save locally then copy project files to those types of drives and vice versa).

It’s frustrating that we haven’t been able to fix this yet but we are at the mercy of Adobe and Harman (who support the Air platform) here. As soon as they release a fix, we will update the app with that fix.

Can you try the simple workaround and let me know if that allows you to save? I’ll be standing by here, Chris.

I changed directories to Downloads and was able to save and export.
A notification of some sort (maybe in the dialog box) about this issue would save you and the user time and frustration.


1 Like

I have the same problem. Can’t save as after upgrade to Catalina. Tried saving to a different folder, no luck. The save as dialog box just freezes for approx 30 seconds. Can’t cancel out of it after it comes back either. I have to kill the app to get out. Using version 3.5.17.


Hi Larry and sorry for the trouble with that one.

Have you tried saving to a different local folder when the issue occurs or did you only try a shared/networked folder?

We’ll do our best to help!

Hi, I tried the advice above and tried to save to the Download folder. Like I said, it just freezes when I try to save. When it comes back after 30 seconds or so I can’t cancel out of it. I have to kill the process to close the Save As window.

1 Like

Ugh, we are starting to see this bug more and more.

Would you mind emailing me, Larry? May be easier to troubleshoot that way.