Cannot type the letter f

Hi There, I have a really strange problem, I cannot type the letter “f” anywhere in the app, nothing happens.
I’m using Balsamiq Mockup 3 on mac OS.
I tried to see if I had mistakenly set up some hotkey and I cannot see that I have. Where can I check this?
and I can type “F”.:grinning:
Any suggestions appreciated!

1 Like

Huh, that is pretty weird, @Michelle_Griffin - I’m sorry about that.

I remember there sometimes being weird interactions with Mockups 3, especially on macOS.

Can I ask you to try rebooting your machine, just in case there is something in the background gumming up the works?

Let’s start there, and if it persists through the reboot, we can dig deeper. I will stand by for your response. :slight_smile:

Hi Brendan,
yes I tried that, but it’s been going on for some weeks now, despite reboots.
let me know what else I could check?

Hrm, I remember there being weirdness here and there with keyboard inputs, but nothing that persisted for weeks.

Are you on a MacBook? Are you using the built-in keyboard?

mac book air, using both builtin and bluetooth keyboard.
I’m pretty sure it’s a shortcut gone wrong, when I hit f the Window menu flashes, but doesn’t open.
Is it possible to set up customised keyboard shortcuts in the app?

You can, Michelle, but it’s through the macOS keyboard preferences.

What happens if you hold CMD and hit f? Do you go into full screen?

I don’t seem to have any shortcuts set in the macOS keyboard preferences.
CMD+f does go full screen

I just removed and reinstalled the app and it fixed it. Thanks for your help anyway. solved now

1 Like

I’m having the same issue on a MacBook Pro (Apple M1 Pro), Monterey

Sorry to hear that, @William-Sheehan. Have you tried removing/reinstalling the app by any chance?

I had the same problem, and was able to fix it by opening System Settings → Keyboard → Keyboard Shortcuts → Modifier Keys and changing the Function (fn) key setting from fn to Control. I changed it for my external keyboard only, but this seems to have fixed it for both external and internal keyboards.

1 Like