Cant drag-drop reorder mockups


#1

Im not entirely sure how this is meant to work, but the mockups down the left panel show a grabber when you hover the mouse over them, I presume the intention is that I can grab and drag the mockups to re-order them. However I cant seem to do this. Clicking on the grabber has no affect and there seems to be no other way to re-order the mockups.

Version: 999.57 - 02/21/2015 13:01
Flash Player Version: MAC 11,9,900,169


#2

Hi Beams, sorry for the trouble. This definitely should work for you. I just tested it out, and it seems to work properly for me. As soon as I click and drag on the grabber, the mockup is selected, and a black line shows where the mockup would be.

One thing that I noticed when testing this out in List view (instead of Thumbnail view), is that it works better if I click one first to select the mockup, and then click and drag again to reorder the mockup. I don’t know if that will help you or not.

We’d love to try and reproduce this. I don’t know that we intentionally fixed anything in this area, but just to make sure, could you try updating to the latest beta build? They’re coming hot and fast! :smile:

If you still have trouble, could you try getting a screenshot, or a screen recording or something? I’d love to see what you are seeing and get this figured out. Thanks!


#3

Ive downloaded last nights build and tested again with a clean project and still have the problem. Ive created a .mov file too - but this forum does not allow it to be uploaded. Ive also noticed that I cant drag any of the objects from the top toolbar either, I have to double click on them to create new objects.

Tom


#4

Tom, how bizarre! Could you send your .bmpr file to support@balsamiq.com? That would really help to try and figure out what’s going on. We keep your data in the strictest confidence and only long enough to verify the software is working properly.


#5

Has this been resolved or is there a known fix? I’m having the same issue. I don’t get a “grabber” when I hover over the images in Thumbnail view, or the names in List view. Version: 3.0.2 - 03/08/2015 12:48


#6

Hmm, sorry about that Brett! That is a different issue than hat we have heard of before. And that’s not something that we’re able to reproduce. I don’t know if it will solve it, but could you update to the latest version: http://balsamiq.com/download? Hopefully if you quit and restart the app, that should solve it as well. We’re working hard to nail down all of these little bugs. Thanks!


#7

Updated. Fixed. Thanks!

PS. Nice work on Balsamiq 3. It is so much better-er!


#8

I’m running into this issue as well with the latest 3.1.1 version on my Mac running Yosemite 10.10.3.

Reordering mockups as well as dragging and dropping items from the toolbar doesn’t work. I can doubleclick on the toolbar to add a widget, though.

I tried on my Linux box (running under Wine) and it works great.


#9

Hi, Tomremo. I think you may be talking about something different, but I just want to be sure. When you say you can doubleclick on the toolbar to add a widget, I’m assuming that means you can add controls from the UI Library at the top. Those aren’t re-orderable, however. They’re sorted alphabetically.

This thread is about drag and drop re-ordering your Mockups that appear in the left sidebar “Navigator.” When you hover over a Mockup there, you get a little grip/handle that you can click drag to move a Mockup up or down in the project order. Looks like this:

Are you experiencing a problem with the drag and drop to reorder there?


#10

Hi, Mike,

I’m having issues with both:

  1. if I try to reorder mocks by grabbing the little handle indicated in your screenshot, nothing happens.

  2. When I try to drag and drop a control from the UI Library nothing happens. But I can doubleclick to add it to the mock and then it’s draggable.

In both cases I can select the item (it gets a blue highlight) but it doesn’t register as being dragged.


#11

That sounds exactly like what I experienced and the solution for me was to update Adobe Air to the latest version.


#12

Ah, I see. Sorry for misunderstanding the problem Can you try beams’ suggestion and update Air from here and let us know if you’re still not able to drag and drop: https://get.adobe.com/air/


#13

That did the trick! Thanks for the suggestion, beams!


#14

Aaand… that did the trick. (Searched for a while)


#15

One year later, just had the same problem, and updating Adobe Air worked for me too. Many thanks beams!!!


#16

How do you update Adobe Air? I go https://get.adobe.com/air/ and when I click download it takes me back to the home page.


#17

@robjcast Not sure why it’s giving you the runaround, but we include the Adobe Air installer in the latest version of the app.

Download it and see if that fixes the issue!

We will be here to help if not. :slight_smile:


#18

I’m having this same issue of not being able to drag and drop mockups. The little drag icon appears, I click on it, try to drag but it just goes back to it’s original position. I tried the Adobe Air update but it didn’t work


#19

Sorry for the trouble @cardeo!

This issue reappeared when MacOS X Sierra was launched but we fixed it in a recent release. Could you please update to the latest version (3.5.8) from this page, to see if it helps?

In case the issue persists, please reach out via support@balsamiq.com and we’ll dig deeper!


#20

Yep that fixed it, thanks!