Can't link buttons


#1

Hi, I’m a new user, sorry if it’s a trivial question.
I want to edit the link part of buttons in my mockups, but the option is gone (no compo box with the option to choose the kind of link.) what am I doing wrong?


#2

Hi @Liza,

Thanks for using our little tool.

When you add a “Button” control to your canvas, the option to link to a different mockup should appear by default (screenshot below).

Hope this is what you are looking for. Please let me know if you need any further information, I’ll be happy to help! :wink:


#3

what an I missing?


#4

Hi @Liza,

Thanks to your screenshot I can see now that you are using our web version, myBalsamiq (the screenshot I attached was made from our desktop version).

Anyway that option should indeed appear on your side, sorry for the snag.
Would you mind trying the following steps for me please:

  1. Click on “Close” on the top left side of the editor and choose “Save and Close” from the window that appears.
  2. Re-open your mockup and check if the link option is available.

Please let me know if still doesn’t work, we’ll dig deeper!


#5

it worked…
thanks… I should have done this in the first place. Like any other technology restart and magic happens :wink:
Thank you Virgin.


#6

How do i link the another page. example, i have button “Submit”, create the link to another window/dialog when button is clicked.


#7

Hey @mahi4889,

Thanks for reaching out about this.

Are you using Mockups 3 for Desktop?
If so, you can directly select the desired option from the Property inspector.

In case you are using myBalsamiq, our web version, you will only need to create the “target” mockup and save it before the option appears in you property inspector.

Hope this helps! Please let us know if you need anything else. :slight_smile:


#8

Thanks Virgin. I am using confluence add-on (blsamiq mockup flow).


#9

Thanks for sharing the information @mahi4889.

The links in Mockups 3 for Confluence Cloud work the same way that the ones in the Desktop version.

On the other hand, if you’re using Mockups for Confluence server, here is the related documentation.

Anything else, we’re here!


#10

Got it. I have created another mockup on same confluence page and linked the second one from first mockup button on-click. This works. Thanks

I Removed, second mockup and created third one but link still listing out the deleted mockup. How we can fix it.


#11

Sorry for the snag @mahi4889.

I’m asking our plugin developer, Sax, about fixing this and we’ll keep you in the loop.

Thanks!


#12

Thanks


#13

For what it’s worth, I’m frequently hitting the bug where the “Links” section of the settings page for a particular control shows with no dropdown menu (like the screenshot earlier in this thread). It’s a nuisance, but if I save everything, close, and then come back it always fixes it.

When I work for 30-45 minutes adding mock-ups and new pages, I’m hitting it about once in that time every day.


#14

It sounds like the app is getting grumpy, @Jason_Buckingham. Sometimes a restart is the best medicine.

Make sure you’re running 3.5.5, though, as we have fixed some of those issues in the past.

The native (non-Adobe Air) version will be much less prone to grumpiness. :slight_smile: