Can't save imported project in Mockups 3.0.3


#1

I imported a Mockups 2 project consisting of about 20 wireframes. The import worked well, everything looked just as before. But when I tried to save the project, no new project file was created. The project name is not added to the window title, either.

After some unsuccessful attempts I tried to close Mockups. It warned me that I was about to lose my work. After klicking on “don’t save” Mockups froze for some time, then actually closed.

Only now did a project file appear in the folder where I had tried to save it. But after re-opening the project it turned out to be incomplete - most (if not all) images were missing. It seems to me that after closing Mockups, all project files that I tried to save before were actually created - but with wildly different file sizes…

I’m on Windows 7 and after installing Mockups 3 I updated to the newest version of Adobe Air. Hope this helps!


#2

Ugh, sorry about that Eric! As a quick workaround, could you try creating a new project, saving it right away, and then importing? We’re not sure that will fix it, but hopefully it will help.

For the bigger issue, we’d love to dig in a bit and figure out what is going on. If you could please send us a zip of your 2.2 project that you are importing, and the messed up B3 project file, that would help a ton. We keep your data in the strictest confidence and only long enough to verify the software is working properly.

Thanks!


#3

Hi Ben, thanks for the quick reply!

I tried the suggestion with creating a project first and then importing the wireframes - that worked!

As to sending you the project - I’m afraid I can’t do that, I’m working under an NDA by my customer so it’s not up to me to decide. I also tried two different, older projects, but could not replicate the problem with them.

Cheers,
Eric


#4

I had exactly the same experience as Eric, on three different older 2.x projects. I just updated Adobe Air today. Interestingly, I had successfully imported one of the projects (41 mockups, 53 assets, 1 symbol library) with a beta version of Mockups 3, about a week or two ago.

Like Eric, my projects contain proprietary information, but one smaller could be sent to you if you need it. If so, let me know where to send a copy.


#5

Awesome, thanks Mark. Send it to support@balsamiq.com. I wonder if the recent Adobe Air update is messing with it. Hopefully not, as there’s not much we can do if that’s the case. Thanks for your help!


#6

Hi @Eric_Fehse and @MarkH, we think we have progress on this front. I just posted in another thread about what we’ve found: Bug: Sometimes Cannot Save Mockup.

You have the distinction of being the first reporters, but I commented with all the details there as they are the most recent reporters. :wink:

We look forward to hearing back on your results with the info that I posted. Thank you!


#7

Hi Ben,

Interesting! But I’ve only had partial success with correcting the name of the assets folder. Indeed, I again tried the same project for which I had sent you a copy, and using “Assets” it failed as earlier described. Changing the name to “assets” did indeed fix the problem! . . . for this project.

However, I had another project with the same “Assets” folder name. Failed as expected. Changed the folder name to “assets” - still failed the same way! Note that this project was much larger - 65 mockups, 37 assets, 1 symbol library. An interesting side-note - with the folder named “Assets” Mockups reported only 25 assets (not 37). I also tried another larger project (43 mockups) with the same failed results - this project had always had the folder named “assets” so renaming was not an issue.

So, it seems the name of the asset folder may be part of the issue, but not everything. Regardless, saving an empty project name before importing the .bmml files solves the problem as you suggested originally - this might be the best work-around.

Another interesting observation - on the larger projects, when I do pre-save the empty project before importing the .bmml files, I have observed the directory into which the project has been saved, using File Explorer (Windows 7). During the “drawing” phase of the import, I noticed that a temp file “[projectName]-journal” (where [projectName] is my project’s specified .bmpr file name) being created and removed from the destination folder multiple times. I can see it come and go (create/delete) several times during the import’s drawing phase, and it is always 4 KB in size. It is deleted if the import is successful. However, if the project file is not saved before the importing the .bmml files, I do not see this journal file creation/deletion process. But exiting Mockups after the failed import (if the project is not pre-saved) does create a 4 KB journal file after the exit (and usually leaves it in the folder with the bad .bmpr file). Perhaps there is a problem with this journal file process if the project is not saved before importing?

Anyway, thanks for the quick response and looking at this problem! At least there is a simple and logical work-around. Thanks again for a great product!

Mark Henrichs


#8

Wow, again, this is great information. If you’re willing to give it a try, we have a new release almost ready to come out. We are doing some final testing with it, and are hoping to release it officially in the next few days. Could you maybe try that same scenario that you tested with this version: http://balsamiq.com/download/ondeck/? Thanks again!


#9

Sure, I’ll give it a shot with the next release.


#10

Hi

We fixed some issues related to saving in 3.0.4.
Here are the complete release notes:
http://blogs.balsamiq.com/product/2015/03/24/bugfixes/

As usual you can get the new version here:
http://balsamiq.com/download/

We will continue to investigate the importing issues.


#11

Looks like you got it fixed! I tried (pre-release) version 3.0.5 with both my larger
projects that failed for me before, and both import from the 2.x .bmml files flawlessly! This is without creating the empty project file first, so I tried both the Save and the Save As from the
newly imported project, and both worked fine after specifying the destination project name. I do see Mockups re-load the files during the save, but it does reload fine, with no missing images. The file got saved fine, and I could then close Mockups normally. Reloading the file looked fine. I did not do a lot of testing, but spot-checking a few pages and creating an interactive PDF seemed to work fine.

You guys are great! Thanks again for getting this fixed so quickly!

Mark Henrichs