Chinese Characters Not Displayed Correctly


#1

Does myBalsamiq support UNICODE? The Chinese characters in my mockups are not displayed correctly. See attached.


#2

Since you are seeing some Chinese characters it is working with some Unicode characters. I did some quick testing and it appears that the characters work correctly when editing the mockup. However, after saving the mockup and allow the project to generate an image I do see the boxes for some characters. I also see the boxes in the PDF export. It appears to work for some characters and not others. I believe it maybe an issue with the fonts or encoding when generating images and PDFs.

@siuyee If you edit the mockup do the characters display correctly? Is it only in the project’s image for the mockup and PDF files that you are seeing the problem? Would you be able to post an example of the characters that you are having problems with? Either copy and paste them in the forums or a Word doc?


#3

Yes, all the characters display correctly in edit mode, but some of them show up as boxes in view mode.
For example, 总览 will show up as two boxes.


#4

Hi @siuyee!

Try turning on “Use System Fonts” within MyBalsamiq’s project edit screen. You can find the option under “View” in the top menu – see my screenshot below. I think this will solve your problem :smile:


#5

That worked in my test project. @keith Thanks for finding that.


#6

Thank you @keith. Is there a way to enable that by default for all mockups?


#7

The characters work with the embedded font on the desktop client for exporting PDFs and PNGs. In myBalsamiq it works when editing the mockup but not in the generated image for the mockup or when exporting the PDF.

The use system fonts option works as a work around. However, I think it should at least qualify as a feature request that these characters work with the embedded font. Since they work when editing the mockup, I am wondering if it is something that needs to be tweaked with the image and PDF converter in myBalsamiq. I found mention in the release blog about an automatic fallback for unknown glyphs. I am wondering if that plays a part when editing the mockup.


#8

@siuyee if you turn this option on in one mockup, it should turn on for all mockups within the project. I don’t believe there is a way to turn it on for all projects at once or make it a default setting for new projects.


#9

Thanks for helping @siuyee out @keith. Keith is also right that the font setting is set per project and The handwritten font is the default. You just have to set it once on new projects.