Clickable links in comments


Can I add clickable links in comments? When I add the following link and text in the proper format (with no space between the square bracket “]” and the regular bracket “)”) to a markup comment, it makes the comment blank so that no text and no link can be seen.

“opening-square-bracket"Find Biography Writers"closing-square-bracket”(my-web-url)

If I add a space there, the text appears but the link does not work.

“opening-square-bracket"Find Biography Writers"closing-square-bracket” (my-web-url)

*If I use the actual square brackets it shows only the link text.


Hi @Boballoo,

Good to hear from you again. :slight_smile:

Are you trying to use a web link in a Comment control or in the notes of your mockup?

You can add links in both by using the following format (without the " of course):

“[Here is our website]”("

The only difference is that you will need to press ALT+click if you want to use it in the Comment control (unless you go in the Full Screen Presentation Mode)

Hope this helps! Let me know if you need anything else.


Yes, that is exactly what I am doing, trying to put a web link in a comment but it will not work. If the round bracket is not separated from the square bracket by a space, the comment goes blank, that is, all the text disappears and I am left with the plain yellow comment box unless I double click on the comment and then the text appears in the edit mode. If I separate the brackets with a space “] (” , the text shows but the link does not work and it shows up as text. Can’t figure out how to send you screen shots here.


Are you running the latest version (3.5.5) of Mockups @Boballoo?
If not, you can get it here.

Also, you can share any screenshot here by dragging it to your message while you create it. If that’s not working, please reach out via support@balsamiq, and we’ll take it from there.

We’ll get to the bottom of it, my friend! :slight_smile:


That was the first thing I checked and I was using 3.4 (why doesn’t the software tell us when to update or update automatically. At the very least it should send us a message by email about the new version) so I downloaded 3.5 and installed it. I still get the same issue. The three screenshots show:

  1. the comment with a space between the square bracket and

  2. the comment in edit mode

  3. the comment without a space (its blank)


Sorry again for the hassle with this @Boballoo, what a weird one!

I’ve just tried again but couldn’t reproduce this on my end.

Are you able to reproduce the error in a new project?
If not, could you please send us your BMPR file (where the Comment shows up blank) to so that we can try to reproduce the issue here?
We will keep your data strictly confidential and only long enough to try to debug your issue.

On a side note, you’re not the first to ask about a better update behavior so I’m adding your vote for it. We want to make it better too, probably when we go native! :slight_smile:

Thanks for bearing with us while we try to help with this one, Robert!


I have tested it in a brand new mockup and the issue still exists. See the
attached screenshot which shows you a comment with the space and one
without the space. The one without the space shows a blank comment, but if
I double click it, the text and link show up in the edit mode.

The .bmpr file for this project is 7 MB and will not send so I put a
Dropbox link to it below. (I am going to scale down the size of the .jpg
images in the assets and see if that makes a difference with this specific



Robert Kidd, Editor In Chief


Thanks a lot for sharing the file @Boballoo, that helped a lot!

The issue is caused by some special characters ("&" apparently) in the specific link(s) link used in your mockups and is not only affecting the Comment control. I’ve passed it one to the dev team, so they can investigate it further and try to come up with a fix for it.

In the meantime, I would recommend using a service that helps with shortening a URL (such as Bitly or TinyURL) so that you can avoid the issue.

Hope this helps! Sorry again for the hassle and thanks for the detailed report.


Hi, I’m with @Boballoo on being notified of new updates available. I’ve already solved an issue just by updating, so I’m sure it would be a good thing. :smiley: