Copy As Image invalid without Use Transparent Background


#1

Project with many mockups. There is just one mockup that has this issue.
Ctrl-A to select all. Ctrl-Alt-C to Copy As Image.
Paste into the Scrivener application (awesome for writers) and it shows up as seen in the screenshot.

I can paste it into Paint.exe and it’s fine. Copy/paste from there I get the same result.
Save-As JPG, then Copy/paste and it shows up correctly.
Experimenting with options under Projects>Export it seems after checking Use Transparent Background that the image will paste in correctly. The same anomaly results with “Mockup to Clipboard”.

So… something is different about this one mockup that seems to cause the format to be different, and so far only perceptible in this one other application. Someone could easily say “it must be that other app”. OK, I’d buy that. (Actually I did. ;)) But apparently when I change a setting in Balsamiq it seems to do something different with a different mockup, and that is something that I think may be worthy of a note here.

I copied the data from the one mockup to another and got the same result. So it must be something in the content. When I remove any control, the copy/paste is fine. It’s not like one control is corrupted and a delete/replace might fix it. This seems to indicate something in the underlying structure is corrupt. If I make any change to any control the problem is fixed. So for now I’m going to copy this project to a backup and hope it stays broken so that someone can look at it.

Any suggestions?


#2

Hi @TonyG,

Sounds like a weird one indeed!

Could you please send your .bmpr file to support@balsamiq.com (along with the steps you are taking) so that we can try to reproduce the issue here? We will keep your data strictly confidential and only long enough to try to debug your issue.

Also, are you running the latest version (3.5.7)?

Thanks for the report, we’ll look into it!