Create text link in data grid on column different from the first column


#1

Hi

How do I add a link in a datagrid in a column which is not the first column of the grid?
I can create a text link in a data grid by putting the text between square brackets. But unless I do this in the first column, Balsamiq does not recognise this as a link. Has anyone a solution, or is this a bug/feature request?

Kind regards

Ilse


#2

Hi @Ilse and sorry for the hassle there.

I’ve just checked and you should be able to set up a link in any column, by using the square brackets. Are you using the latest version (3.5.7)?

If the issue persists after a restart of the app, could you please send us your BMPR file?
We’ll keep your data strictly confidential and only long enough to try to debug your issue.

We’ll do our best to help! :slight_smile:


#3

Hi Virgin

Thanks for your quick response.
I’m currently using version 3.3.12, and can’t upgrade to the latest version due to internal company policies :frowning:.
I stumbled upon the issue in a previous project some months ago and today I started a new project and encountered the same problem, so it’s persistent I’m afraid.
I’ll send you the bmpr-file of the new project.

Kind regards

Ilse


#4

We got it, @Ilse! We will start digging in and get back to you a later today (if that is ok). :slight_smile:


#5

Hi @Ilse, we are seeing the same issue in 3.3.12. That was around the time that the Data Grid had trouble parsing markdown properly, I’m really sorry about that.

The good news is that we have fixed that issue, and I confirmed that your data grid is displaying links correctly in the current version (3.5.7). Is it possible for your IT department to update the app for you and your team?

If not, using the rectangle link the way you did is probably the best workaround for this bug. Good thinking! I know that’s a lot of extra work (and I am sorry about that), but it will get the job done. :slight_smile:

Keep us in the loop as to whether or not you’re able to get the updated version of the app, or if you run into any other weirdness!


#6

Hi @phil

Thanks for looking into this little issue!

I’ll contact our product manager to see wether we can update Mockups.
Meanwhile we’ll use the rectangle workaround :slight_smile: .


#7

Just discovered another workaround (thanks to my colleague Sonja for the tip):
You can type the destination of the link between brackets behind the link.