Creating links containing a blackslash


#1

I am trying to create a label that contains a link with a backslash in it. The full content of the label will contain both plain text, as well as link text.

I have tried [text\\], but this doesn’t work - it ends up being displayed as [text\] without being treated as a link.

I have also tried {color:blue}&text\\&{color}, but that suffers from a similar issue - the blue formatting is applied, but text is shown as &text\&. The blue is a different shade of blue to the other links, but that doesn’t really matter as this isn’t a suitable workaround.

I think I’m going to have to work around the issue by splitting the text up into multiple labels so that I can apply the formatting using the settings that affect the whole label, but it would be nice not to have to do so.


403 when I try to change a post
#2

Have you tried [text\] ?
As far as I know you can escape a character with the backslash, so the first backslash is escaping the second and is therefore not shown.


#3

since I got problems to edit my answer: The backslash also got escaped in this forum, so maybe you could try three backslashes (not one like it is visible in my previous post) :smile:


#4

I decided to try the various posibilities, and here is the result:

Each line contains more backslashes than the one before it.

Looks like the closest I can get is to use &{color:blue}text\{color}&. Any of the other options ends up distorted in some way. The colour will be wrong, but that’s not the end of the world.


#5

Hey @garethm

Thanks so much for taking the time to run those tests for us. I have filed the bug in our tracker so that our devs can have a look at it.

I’m sorry for the hassle.