CTRL+C, CTRL+V & CTRL+V Don't Work

CTRL+C, CTRL+V & CTRL+V - Non of them work. I use Balsamiq Cloud, on Windows, Chrome. Chrome is up to date.

I try to use CTRL+D, but sometimes it doesn’t work as well - it promptes Chrome’s bookmarking feature instead of duplicating elements in my mockup.

Couple days back, everything was allright. I believe it is a new bug related to Chrome’s newest version: 109.0.5414.120

Ugh, I’m sorry about that, @Tiko_Kiladze.

I ran some tests on Windows 11 with 109.0.5414.120 but couldn’t reproduce the issue. I’m wondering if it has something to do with an extension that got updated recently.

If you open up an incognito window, log into Balsamiq Cloud, and try again, does it work? Let’s start there, and then we can dig deeper.

I’ll stand by for your response. :slight_smile:

When I first switched from Desktop to Cloud version, I thought I was losing my mind when simple copy/paste did not appear to be working. I have noticed two things that might/might not help.

  1. There is sometimes a noticeable lag (we’re “up in the clouds” now :slight_smile: ). I will paste a 2nd time, and suddenly I’ll get two copies pasted when everything catches up.
  2. There seems to be some sensitivity to where the focus is on-screen. If I am not pointing right over the main pane the paste won’t work. To remediate this, I have taken up the habit of always clicking once somewhere in that pane before doing the paste - never fails me when applying that routine.


I had the same problem.

Try this:
How to Enable and Use Clipboard Sharing in Google Chrome (howtogeek.com)

I think it is a security setting in Chrome that changed with the new version.



1 Like

UPDATE: I guess I spoke too soon earlier with my “never fails me” comment. I am still seeing this behavior (more of an annoyance than anything), and slightly more frequently.

  1. Select an object and ctrl-C.
  2. ctrl-V. Nothing happens.
  3. ctrl-V again - you get two copies of the object.

Mildly irritating, especially if you have ‘rubber-banded’ a set of objects. You can nuke the second set, because they are all still selected after the paste, but if you didn’t quite “aim your paste target” into a totally blank area of the pane, you’re left with misc. objects scattered all over the top of other objects, and you have to go cherry-picking to get them all.
(“Aim your paste target” Sounds like an FPS I should write… < grin >)

Hey Steven,

This sounds like maybe the clipboard history is getting gummed up. Check Settings > System > Clipboard, and you should see a toggle for the clipboard history. Try toggling it off and then on and let me know if that resolves the issue.