Difficulty editing symbol--bug? corrupted symbol library?


#1

Hello, I have created and saved symbols, which I have successfully edited. However, it seems like my symbols library got corrupted when I downloaded some symbols from Mockups to Go. I am no longer able to edit them.

Here’s what is happening:

  1. I try to edit them using the procedure outlined here: https://docs.balsamiq.com/mybalsamiq/symbols/#editing-a-symbol-source.

  2. But when I try to edit one symbol, I get a mishmash of all the symbols I’ve created together. They are in one view, squished on top of each other in what looks like a mockup. This is located under symbol libs>symbols. In addition, cannot find the symbols I have created when I am in mockup view and go to project assets.

Would someone please advise? I wish I could show a screenshot. Thanks!


#2

I’m sorry about that @sheila_walsh, let’s see if we can figure out what’s going on here.

Since you’re a myBalsamiq user, would you mind emailing support@balsamiq.com, and we can troubleshoot this that way?

I’d like to take a peek at your account, so going back and forth over email will probably be easier. I’m here until ~5 pm CST, and Virgin starts at 9 AM CET. One of us will be able to get to the bottom of this!


#3

Thanks, Brendan. I appreciate your reply. I will e-mail with a screenshot of what is going on.

Best,
Sheila


#4

I believe I am having the same issue with my symbols being all jumbled up when going to edit one. Is there a fix for this issue?


#5

The symbol library in myBalsamiq is a bit of a mess, @cnujjf. I’m sorry about that. It’s basically just a special mockup without any sorting.

One of the things we did for Mockups 3 for Desktop is we allowed you to select individual symbols from the navigator. That feature is coming to the next generation of myBalsamiq, which we hope to have a closed beta of soon.

I’m sorry that it’s a hassle to deal with now, but it will get better!

Let me know if there is anything we can do to help with it. :slight_smile:


#6

Hi, I’m having a similar issue here. The usual way I edit symbols is I double-click the instance in the mock-up and then I hit the “Edit” button on the “Want to edit the symbol source instead?” message.

It sometimes works well, but others it shows the same mishmash @sheila_walsh describes.

Also, if all’s going well and the symbol appears on its own, if I double-click one time too many (for instance, when I edit a group nested several times and I double-click outside several times in a row to get out), I end up in the mishmash again.


#7

Sorry for the hassle with this, @JuanMejiasGoma.

Double clicking numerous times on a blank space of your symbol will indeed bring you back to the Symbol library it belongs to, this is an alternative way to access it if needed.

On the other hand, clicking on the Edit button from the Mockups view should bring you directly to the corresponding symbol, and not to the Symbol library.

First, I would suggest updating to the latest version (3.5.3) to see if it helps.

Then, if the issue persists, could you please send us your BMPR file to support@balsamiq.com so that we can try to reproduce the issue here?
We will keep your data strictly confidential and only long enough to try to debug your issue.

We’ll get to the bottom of this! :slight_smile:

PS: On a side note, you can re-organize the Symbol library view at any time if needed.


#8

Hi @Virgin,
I updated recently to the latest version (thanks to your advice :slight_smile:), and it solved an issue with asset importing.

Regarding the double clicking, I can see now that it’s by design, but I still feel it’s maybe too easy to end up in the library unintentionally. I realize that it’s a bit subjective, though, so maybe I’m just being whiny :sweat_smile:.

The issue with going to the library instead of the symbol has been happening all morning, but it’s not happening now, after I rebooted my desktop. If it continues I’ll send you the file.

Thanks for your help.


#9

Sorry @JuanMejiasGoma! I should have looked more carefully… :see_no_evil:

Let us know if this one continues to annoy you, we’ll do our best to help!


#10

Nah, don’t worry @Virgin, I wouldn’t expect you to keep track. I was just being grateful for your help.

Yes, I’ll let you know if I keep seeing the issue. Thanks again.


#11

Actually, we usually do @JuanMejiasGoma. So, my bad. :slight_smile:

By the way, I’m adding your request about the double-click behavior when working inside a symbol (e.g. editing a group), I can see how useful that would be.

Thanks again for sharing your thoughts today, that helps us a lot to make the tool better!


#12

Hi @Virgin,
Unfortunately, I keep having the mishmash issue. Before, the symbol being edited appeared on top, but now sometimes it gets buried in the symbol stack.

For instance, when I want to edit this symbol:

I get this right after I hit the ‘Edit’ button:

The one I want is hidden somewhere below there. The other symbols can’t be edited or moved aside, so I can’t see what I’m doing. This is making it difficult to use the tool.

This doesn’t always happens, and I can’t tell what prompts it. I have the feeling that the problem ‘builds’ with time, so that it’s more prone to happen after working on the app for a while, and it gets better if I reboot. But I could be wrong.


#13

Hey @JuanMejiasGoma,

Sorry to hear that you’re still having troubles when editing your Symbols. :pensive:

Would you mind sending the BMPR file to support@balsamiq.com so we can have a closer look?
I know that you don’t have reproducible steps for now, but feel free to include any detail that might help with it.

We’ll do our best to help, my friend.


#14

OK, I’ve sent the email. :relaxed: