Balsamiq Community Discussion

Down Arrow does not work for nudging control


#1

(SOLVED) For fine 1 px adjustments of controls, the three arrows (left, up, right) work impeccably, but the down arrow now does nothing. This needs fixing.

(Running Balsamiq Mockups Version: 3.5.16 - 08/06/2018 06:07
Adobe Air Player Version: Mac 30,0,0,11)


#2

Sounds like another weird one, sorry about that @Odd_Wiking_Rahlff!

I’ve just tried and it seems to work fine on my end, does it persists after restarting the app (or rebooting your Mac)?

Any chance that the hardware might be having issues or does the down arrow work fine while using other softwares?


#3

No, the down arrow works nicely elsewhere, but it consistently fails to respond within Balsamiq even after total reboot of the Mac.


#4

Is the issue specific to one fo your projects?

If that’s the case, could you please share it via support@balsamiq.com so we can take a closer look?


#5

No, it happens for every single one. Even a brand new containing just a single control.
The problem definitely seems to be the tool.

Did you try on a Mac?


#6

I’m trying from a Mac, running Mojave version 10.14.2. Are you running the same OS version?


#7

Indeed.


#8

Let’s check a couple of things:

  • Does SHIFT + arrow works?
  • When selecting a coordinate field from the property inspector, does the arrow work to change values there?

#9

SHIFT + arrow works for all but the down arrow
For changing coordinate values, only up arrow works (for increasing the number)


#10

Thanks for checking.

I know you’ve mentioned that the down arrow seems to work fine with other softwares but do you have another keyboard at hand to try it out?

I assume the issue is relatively new, correct? Have you changed anything before the issue showed up? New keyboard layout or anything like that?


#11

Ah, that made me check, and I found the culprit!


#12

Nice catch! Thanks for letting us know @Odd_Wiking_Rahlff.