Editing symbols is terribly slow


#1

I’m working on a mid-weight project currently. Nothing too big or too fancy.
I imported the project from a Mockups 3 file and have continued working on the project in Balsamiq cloud.

But after a while I ran into the following problem. When I’m editing symbols in the source editing mode. The application becomes very slow. Dragging around objects is a difficult job suddenly. When switching back to the mockups editing view the application responds normally again.

Anyone else experiencing these problems?
Hope you guys can help me out here.


#2

Hey @WeeDz! Long time no see, my friend. I hope that things (aside from this) are going well. :slight_smile:

It sounds like you have a lot of symbols in your symbol library. Is that the case? Would it be possible for us to take a look at the project and see if we can figure out what’s happening?

We do have this FAQ which may help speed things up (depending on the problem), so you can also try that.

Let me know if we can take a look at your project, and we will go from there!


#3

Taking a look is fine with me. It’s in my cloud account. I’m assuming you can see these projects yourself.
Project: Advies tool fiscalist_004


#4

So it’s not running slow for me, but there is something up here. I’m going to share the file with @Florian_Brauer and see if he can poke at it and figure out what’s going on.

He is out until Monday. Are you good working as is until then? Or do you want to see if it works better in Mockups 3 for Desktop?


#5

I’m ok until Monday


#6

Hey WeeDZ,

I can see what you mean with terribly slow…

There is definitely a bigger issue. We have some improvements that are being tested. But even with those the performance is poor.
You use a the Block of text control quite a bit. I cannot tell yet, if that is the culprit but we know for certain that is know to take a lot time to be measured.

It is definitely an issue in our codebase, where a calculation takes a lot longer than it should.


#7

Hi Florian,

Thanx for the update, i was away for a week or so, so sorry for the radio silence. As of now I’m in the phase of stripping away the blocks of text, replacing it with real (dummy) text, so hopefully that’ll speeds things up.
Is the issue on your backlog at all? Just checking, otherwise i’ll have to move to balsamiq desktop again.


#8

Hey @WeeDz,

The dev team is actually working on this right now. I don’t know when it will make it to the release branch, but it is something they are fixing as we speak. :slight_smile: