Balsamiq Community Discussion

Embed PNG URL getting error when viewing

Each time an embed link is copied from a wireframe thumbnail and pasted into a browser to test we get the following error “Unable to get the authorised URI”. It has worked sporadically and I figured there must be an issue balsamiq is working through, but it has persisted for about a week. Can you please advise if others are having this issue as we use this feature extensively within our Jira cards.

Ugh, I’m sorry about that, John.

I’m going to see if I can flag down Sax or Stefano about this.

Just to cover our basic bases:

  1. What browser are you and your team using
  2. Does it happen in different browsers as well?
  3. What about private browsing windows?

Let’s start there, and then we can work on a solution.

Hi Brendan:

Answers to your questions

  1. Chrome on Mac
  2. Yes
  3. Yes happens there as well

So it doesn’t appear to be browser specific, but I did discover that it seems to be related to a specific Confluence page/project that worked fine for a long time and then stopped working. Is there something that can be done to corrupt the project? I tried testing with a new project and re-ordering the page that contained it and couldn’t cause it to break.

Hmm, it sounds like the source image may be getting corrupted on that page (for whatever reason). I’d like to try refreshing the images.

If you open up the project, select Project > Export > Export to PNG, and then choose to save the PNG files to your Confluence Page, does the image URL work again?

If that doesn’t work John (including trying to Save from the Project menu), would you be able to invite us to your instance so that we can take a look?