Export stuck on project


I have the Mac version 3.5.7. I have multiple projects open at once and I export to PNG from one of them. If I then try to export from another project, it is stuck exporting the screen from the previous project.


Sorry for the trouble with your PNG exports, @AJKock.

I’ve just tried to reproduce the issue but the export worked fine for both projects on my end. Have you experienced the issue when working on any project(s)?

Also, would you mind updating to the latest version (3.5.9) to see if it makes any difference?

In case the issue persists, could you please share some details about the configuration that you’re using? Feel free to send any screenshots or screencast via support@balsamiq.com if that’s easier.

We’ll do our best to help! :slight_smile:


Ok, I think I found the problem (where it gets stuck). So I use “Window - Merge All Windows” and this is when the problem occur. If I drag the project away from the grouped windows, it works again.


Thanks for the heads up @AJKock. Looks like a conflict between Adobe Air and Windows, hopefully our next major version (native) won’t cause this issue anymore.


Just to make sure, we are on the same page :wink:
I’m on a MAC, so it is the “windows” functionality of the MAC OS and not Microsoft Windows.


Sorry that we missed that, @AJKock.

Does this only happen when you have multiple projects open? Are you able to export if you close everything and reopen just the one project?

This still sounds like an Adobe Air thing (it gets grumpy when it starts taking up too much memory), but if there is another bug at play, we would love to get it fixed.


Yes, it only happens when I have multiple projects open and they are “merged” into one “window”. If I drag it away from the group, the export works properly again. Usually the first wireframe I work on, on the day will export, but if I then switch to another project, it is stuck on that previous project. If I close Balsamiq and relaunch, it works again, but only for the one project.


Huh. I’m really sorry about that. What a weird bug.

Would you be able to share your project with us, so that we can test it on our side? If so, just email it to us and we will start digging.


I usually have about 5 projects open. Do you want me to send you all of it? :slight_smile: It happens intermittently. If I send you a video, will that not help? It doesn’t happen with specific projects.


Thanks for sharing the video @AJKock, that helps indeed. I’ve just tried to reproduce it in version 3.5.9 with 5 projects and I was able to export a PNG from each project without any issue.

I’ll reply to your email since it may be easier to communicate quickly there and share information and we’ll go from there.


Sorry, things are a bit busy at work. I will create another 5 projects
soon. Like I said, the problem is intermittent, so creating 5 new boards
might not immediately give the error. Try leaving the 5 projects you
created open and export a couple of hours later.

What I noticed today, was that not only did it use the previous file’s name
(from the other project), but it actually exported that particular board.
It wasn’t just a name confusion. The export was actually still “stuck” on
the previously exported project, even though I “tabbed” away to another
project, and are trying to export that project’s one file. PS: I am doing a
one screen export and not a complete project export.


I think I have found/solved the problem. Break up the “Merge all windows”, you can export normally again. So the bug appears after while of using “Merge all windows”.