Feature request - show/hide option for iPad/iPhone/Smartphone


#1

I’m currently designing a tablet app, and all of my mockups have the iPad border around them so that they look good when presenting from my PC.

I also need to export the project as a PDF for demoing on an iPad (I’m using Link Viewer). Obviously in this scenario I want to get rid of the iPad borders so that it looks realistic on the iPad screen.

I couldn’t find an easy way to do this, so I ended up duplicating the entire project and manually deleting all of the iPad objects. Is there an easier workaround that I’m missing?

It would be great if there was a toggle to show/hide all iPad/iPhone/Smartphone objects, in the same way we can with markup.


#2

You can treat the objects as markup but that would be manual effort. If you just want to hide the borders this could nevertheless be an option.


#3

Hi @Chris_Gatland,

Marking your iPad controls as Markup would be the best way for this indeed!

Then, you will only need to hide the Markup items and export your project to PDF to get the desired result.

Hope this helps! :slight_smile:


#4

That would be fine, except I sometimes need to export with the iPad controls, and without markup.

Same for presenting in fullscreen mode from PC - there I want the iPad, but no markup.


#5

That’s a good point @Chris_Gatland! I’ve just added the feature request to our internal tracker.

Thanks for sharing your use case!


#6

@Virgin - I found a good workaround for this:

  1. Convert the iPad surround to a symbol and use it in all mockups (I’d actually already done this, as I needed to include a consistent button link for the iPad home button in all mockups)
  2. When you need to export without the iPad, edit the symbol and select the “Treat as markup” option. You can then hide it along with the other markup, do the export and then revert it back to non-markup status afterwards.

A dedicated feature would still be nice, but the above method works well in the meantime :slight_smile:


#7

@Virgin Hmm - seems I spoke too soon. The symbol/markup workaround worked perfectly the first time I tried it, but having done it again, the mockups are exporting with a large border (as if the iPad is still there, just not visible). Hence my proto is not at full-screen when viewed on the real iPad. I’ve tried a few different export options, but no joy.

I did update to 3.5.15 yesterday, so maybe this accounts for the difference?

sigh…


#8

Ah, right! Sorry that I missed that this morning.

The Symbol’s frame still appears in the exported PDF, like in previous versions. The feature request would be the best way for this one.

Thanks for trying out, Chris!


#9

It’s weird because, like I said - the first time I tried this it worked perfectly, and I got a nicely cropped output file. :confused:


#10

…also, the iPad is the only bit of markup that gets invisibly included like this. I have loads of sticky notes, drawings etc that are treated as markup, but they have no effect on the sizing of the pdf page.


#11

An update on this issue - I just found that Adobe Acrobat DC Pro has a “crop page” tool, which allows you to apply a crop window to all pages in a document. This has allowed me to get rid of the unwanted invisible iPad frame in my exported PDFs, so I can FINALLY do proper on-device testing, whilst also using the same BMPR file for presentations etc with the iPad bezel on screen!


#12

Thanks for the update, Chris! This might be useful to other users. :slight_smile: