Balsamiq Community Discussion

File Icons Broken

Sometime within the past week my Balsamiq file icons disappeared. It was either after licensing my software or a software update. Any ideas how to bring them back?
Screen Shot 2021-04-06 at 3.52.46 PM

Hi there @jkmoses ,

Thanks for the post and sorry for the annoyance here. This should be a relatively simple fix - can you please make sure you’ve installed the latest version of the app (4.2.3 for macOS): Balsamiq for Desktop - Fast, Powerful, Offline Wireframing | Balsamiq

Then can you log out on your Mac and log back in again - the issue should be resolved.

Let us know if you continue to have issues and we’ll go from there, ok?

@alasdair That is the version I’m currently running already. Any other ideas?

Did the issue persist after you logged out and logged back in? If so, can please restart your Mac ( > Restart…) and tell us if the issue is resolved?

I logged out and back in and have multiple times with no resolution.

Thanks @jkmoses,

Restart also no effect?

If you open Balsamiq Wireframes for Desktop and create a new project, does it have a visible icon?

From there, if you open the circled project in your initial message, make a change to it and save the project, does it continue to have no visible icon?

Restart = no effect
New project = no effect
Updating and saving existing project = no effect

OK thank you. I need to loop in some engineering help on this one. Can you let us know which version of macOS you’re using?

I am seeing the same problem running on Mac OS Big Sur. At some point in recent history the Balsamiq icons stopped showing in Finder.

Yup, it had to do with us changing the minimum requirements. The fix will be in 4.2.4 which will ship later this month.

Sorry about that, friends. I know it’s annoying - we are all fighting with it right now. The fix is coming!

2 Likes

I’m also having this problem. I downloaded 4.2.4, and restarted my computer–still no icons.

I tried opening one of the files, and saving a copy of it with Save As–still no icons.

1 Like

Hi @Liz_Lawley and sorry to hear that this one still bugs you.

Just wondering, do you have any older version still installed on your machine?
If so, could you please try to delete it?

Once that’s done, could you try to:

  • Restart your machine
  • Move a BMPR file to a different folder and see if the icon shows up

We’ll stand by for your reply

I’m also having the same problem. Installing the update didn’t change anything.
Screen Shot 2021-04-19 at 10.42.38 AM

Hi @jkmoses, Would you log out on your machine and log back in and tell us if the issue persists? Thank you!

I have logged in and out of my machine several times since I installed this update last week and it hasn’t fixed anything.

So something bizarre just happened. I simply moved the file out of the folder and put it on my desktop. The icons started appearing. I don’t get it.

Thanks @jkmoses. We’ve not seen a case where updating, editing a project and logging in and out did not resolve it.

This is a bit of an ask but could you:

  • Ensure that your project files are saved somewhere other than the Support Folder. Please do not proceed unless you are 100% sure your projects are saved safe in a known location
  • Install AppCleaner (it’s free)
  • Run AppCleaner and completely remove Balsamiq Wireframes for Desktop by dragging the app icon from your Applications folder into the running AppCleaner window
  • Reinstall version 4.2.4 of Balsamiq Wireframes
  • Log out and log back in

Is the issue resolved?

If you’re not able or not comfortable installing AppCleaner, just let me know and we’ll work round that. Thanks for working through this with us!