[FIXED] [bug?] "Boken: action://back" when assigning "go back" to text link


#1

Balsamiq Edit: This has been fixed in version 3.4.2


I’m setting up a text widget, with a link contained in it (like “bla bla [linktext] bla bla”). In the property widget I can assign the link action "Go back (in full screen) to it, but then the link shows an exclamation mark, and the links says that it is broken.

Is there any reason a back-link cannot be assigned to text links? It works for buttons though.
My Balsamiq version is 3.4.1

Any clarification would be very much appreciated.
Thanks,
Ralph


#2

Hi @ralhei,

Sorry for the hassle with this one, that’s actually a bug we need to fix.

We implemented this feature recently and missed the snag. I’ve passed it on to the dev team and I’ll let you know as soon as we have a fix for it.

Thanks for the report, Ralph! Please let us know if we can do anything else for you. :slight_smile:


#3

Hi @ralhei,

We just released our latest official version (3.4.2) including the fix for this one!
Thanks again for the report! :slight_smile:

The new version (3.4.2) is available here.
And the complete release notes are here if needed.


#4

Seems like this is still broken when the mockup is exported to PDF. When I have a back link applied to text or icons the back link works fine when running in Balsamiq in full screen mode. But when I export it to PDF, the back links show a cursor with a ‘W’ overlaid on the hand cursor in PDF Reader. There is also a tooltip associated with the cursor showing “action://back”.

All of the other links seem to work fine. There is a security alert that comes up the first time related to back links, but if you select Allow and check the box to always allow back links they still don’t work.


#5

Unfortunately, @DavidV, the Backlink only works in full-screen mode. PDFs don’t have a command to jump to the last viewed page, so we couldn’t add it there.

I’m really sorry about that :(.


#6

Okay… makes sense. Thanks for the quick reply!