Balsamiq Community Discussion

[FIXED] Bug? Full screen presentation settings not remembered slide to slide

Balsamiq Edit: This has been fixed in version 3.3.11

Using B3.3.3, something strange is going on with full screen presentation mode. It does not usually remember the settings I give it.

I think what’s happening is that it takes some amount of time to “save” the fact that I toggled that setting (several+ seconds) and it toggles the display every other slide if I don’t wait long enough. So, what I see is this:

  • Mockup1 - markup is off. Turn markup “on”
  • Flip to Mockup2 - markup is off (when I’d expect it to be on).
  • Flip back to Mockup1 - markup is still on - good.
  • Flip back to Mockup2 - markup is still off, so I flip it on.
  • Flip back to Mockup1 - mark up is now off

As I was testing this to find a theory, I found if I flipped the toggle on Mockup1 and then waited several seconds, then everything worked as expected.

It’s quite a mystery. Thoughts?

Hey @grebe,

Good to hear from you again but sorry for the snag! Looks like a weird one.

I couldn’t seem to reproduce the issue on my end (tried on Win 7, Win 10 and OS X El Capitan). I think you do, but would you mind checking that you are running the latest version 3.3.3? You can grab it here if needed:

Are you seeing the same issue if you create a new project? If not, would you mind sharing your BMPR file with us so that we can try to reproduce the issue here? As always, we’ll keep your data in the strictest confidence and only long enough to try to debug your issue.

Also, would you mind detailing on your configuration (OS mainly) so I can try reproducing this one with the same configuration you are using?

Sorry again for the hassle with this one, we’ll do our best to help with it!

Merry Christmas! :christmas_tree:

I def. checked that I was using 3.3.3 (and I just checked again, but I am). I am seeing the same issue if I create a brand new project (demo project attached here). I also noticed that if I’m in presentation mode, toggle markup off on p1 and hit Page Up, then the toggle seems to switch back and forth. Same thing happens on the last page if I hit Page Down. Unsure if that’s related to this issue, but it didn’t seem to be.

Windows config is: Windows 7 Enterprise SP1 / 64-bit

demoproject.bmpr (33 KB)

1 Like

I suspect that, given the delay, it has to do with the app redrawing all the Mockups.

Let me see if we can poke at it and figure out if there is something else gumming up the works. Thanks for checking back on this, Renee. I hope your holiday was awesome :slight_smile:

1 Like

Hi @grebe,

We just released our latest official version (3.3.11) including the fix for this one. Thanks again for the detailed report and help!

We’re here to help if you need anything else. :slight_smile:

The new version (3.3.11) is available here.
And the complete release notes are here.