[FIXED][bug] Hide/show markup no longer working in 3.4.1


#1

Balsamiq Edit: This has been implemented in version 3.4.2


I’ve been looking for a bug report form, but I guess it’s ok to post a bug report to this forum.

Anyway, I’ve noticed that in the latest version of Mockups for Desktop, 3.4.1, I can no longer use CMD+K (I’m on a Mac) to show and hide markup in my wireframes.

I first thought this was only happening with existing elements I “treat as markup” using Shift+CMD+K (which still works), but it also happens with actual markup items such as the yellow sticky notes. I’ve also tried this with a new project, as I noticed this on bmpr files I create with a previous versions of Mockups, but it doesn’t work in both.

Cheers
Andreas

Environment: Mockups for Desktop 3.4.1 on Mac OS X 10.11.5.


#2

Hi @weder,

Hope you’re doing well. :slight_smile:
It’s totally fine to report a bug in here, as well as via support@balsamiq.com if you prefer this way.

We were able to reproduce the bug by following these steps:

  • have only one project opened
  • close it
  • reopen the same project or a new one

This leads to the Markup item being disabled in the View menu:

We’ll work on fixing it but in the meantime, you should be able to avoid the issue by either avoiding quitting a project when you have only this one opened or by restarting the app.

Sorry for the hassle with this bug and thanks a lot for the detailed report! Let us know if you need anything else.


#3

Hi @weder,

We’ve fixed this bug in our latest beta version available here.

Just the usual word of caution: as this is a pre-release version, we don’t recommend using it on mission-critical work. The fix will also be included in the next official version.

Thanks again for your report! :slight_smile:


#4

Hey @weder,

Just so you know: we just released our latest official version (3.4.2) including this fix.

The new version (3.4.2) is available here.
And the complete release notes are here if needed.


#5

Hi @Virgin,

back from my vacation and bang great news: thanks for fixing this so quickly.

Cheers
Andreas