[FIXED][BUG] Quick Add Shortcut ("/" or "+") often stops working on Mac OSX


#1

Balsamiq Edit: This has been implemented in version 3.4.5


The quick add shortcut often stops working. Restarting Balsamiqs fixes the issue.


#2

Hmm, this is not something that we have seen. And we have done a lot of testing on Mac OS X. Could you try updating to the latest version and see if it still happens. If so, we would love reproducible steps. Since we’ve not seen it, we would have a really hard time figuring out what’s going on and trying to fix it. Thanks!


#3

I’ve updated to the latest version and it turns out ALL keyboard shortcuts stop working occasionally. I’ve been unable to figure out exactly what the steps are to reproduce. Is there a debug log I could capture and send along when I get the application into a state where it stops responding to keyboard shortcuts?


#4

Hi, I’ve had this bug since early versions of Balsamiq Mockups 3 on Mac OS X. After a while, pressing “+” does not replace the text in the Quick-Add input field but rather adds “+” in front of the text “Quick Add”. This is really annoying! :confused:

To reproduce, start a new project:

  1. Press “+” and type anything you want
  2. Press Cmd+A to select the text in the Quick-Add input field
  3. Use mouse and click anywhere to de-focus the Quick-Add input field
  4. Press “+” -> BUG

Please fix this soon :smile:


#5

Hey @usability,

Sorry for the snag!

I was able to reproduce the bug here in the latest version (3.2.3) and I passed it on to the dev team so they can look for the root cause of this. I’ll let you know as we have a fix for it.

Thanks for sharing the reproducible steps, that was very helpful!


#6

Hi! Thanks for your quick reply. I’m glad I could help. :smile:


#7

Hey @Virgin, when are you going to fix this bug? This is soooo annoying! :disappointed:


#8

I’m sorry @usability; this one fell off our radar.

I’ll check in with the team at our next support meeting and see if there is something we can do about it.

Thanks for the nudge on this. I’m sorry that we lost track of it.


#9

Cool, thanks for your quick reply!


#10

I have this bug also on Windows 7, Mockups 3.4.1

Balsamiq Mockups Version: 3.4.1 - 05/30/2016 14:00 Adobe Air Player Version: WIN 21,0,0,174

Happens very consistently, about 95% of the time. Will this be fixed soon?


#11

Hey @JA11,

Tracking down and fixing this is one of our active projects. We will update this post once we get it fixed!

Thanks for you patience on this. :slight_smile:


#12

Hey @usability and @JA11,

We just released our latest official version (3.4.5) including the fix for this annoying bug!
Thanks again for the report! :slight_smile:

Hope this was the one @Colin_Heics was seeing too. Let us know if you still see any issue.

The new version (3.4.5) is available here.
And the complete release notes are here if needed.


#13

Thanks @Virgin! You just made my day :slight_smile: