[FIXED] Cannot drag and drop elements (MacOS Sierra)


#1

Balsamiq Edit: This has been fixed in version 3.5.3


Making a bit of an assumption here, but since upgrading to MacOS Sierra BETA, my Balsamiq (3.4.2) no longer allows me to drag elements onto the workspace :frowning:

What should happen:
When clicking, dragging and dropping an element on the workspace it should appear then and become an editable element.

What does happen:
When clicking, dragging and dropping an element on the workspace it does not appear there.


#2

While we aren’t running the macOS Sierra beta in-house yet, @curdatron, this is something we will definitely be keeping our eye on. It looks like Sierra and Adobe Air are fighting :(.

Thanks for the heads up on this, Matt!


#3

Same problem is being faced by me


#4

+1

Same problem is being faced by me


#5

Still an issue in Public Beta 2 or Developer Beta 3?


#6

Yes, still an issue on beta 2, I’ve tried update Air but it didn’t help. Also, I can’t reorder mockups in sidebar.


#7

Same problem on Beta 3 (16A254g) I’m afraid.

I don’t suppose there is any chance of temporary access for the in-browser version of Balsamiq, or the JIRA one, is there?

I’m happy to BETA and UAT test anything if that helps.


#8

Thanks for the heads up @curdatron and sorry for the hassle with this.

All our versions come with a 30-days trial so this might help in the meantime. Please head over to this page if needed. Mockups 3 for Google Drive might be an option to consider since the version is identical to the Desktop one you are using already.


#9

Beta 4 has the same problem also cmd+с / cmd + v / cmd + z doesn’t work now.


#10

Are you on 3.4.4, @Stanislav_Skrebkov? It probably won’t fix the dragging, but it may fix the shortcuts.


#11

@Brendan switched to unstable release, it didn’t help with dragging, but solved shortcut issues


#12

+1 Can’t drag and drop nor use CMD shortcuts. Latest public version of Sierra and latest public Balsamiq versions.


#13

Same issue, latest OSX Sierra


#14

I just wanted to add my voice to confirm drag and drop does not work in the most recent version of Balsamiq (version 3.4.5) on the most recent public beta release of macOS Sierra - version 10.12 Beta (16A313a).

This problem applies to dragging elements from the UI Library and rearranging the order of Mockups (thumbnail or list).

The latest update of Adobe Air (version 22.0.0.153) does not resolve the problem.


#15

Thanks for continuing to keep us in the loop on this, friends. I have a Macbook running the Sierra beta now, and we are actively monitoring this now.

We are still probably a month away from the official launch. One way or another, we will get drag and drop working again. :slight_smile:


#16

Hi all,
We have similar issues with happymetrix.com since Sierra. Adobe Air beta 23 did not fix the issue. Hope to see progress soon. Also Office (Outlook, Powerpoint, Excel) keeps crashing on me with Sierra GM.
thx
John


#17

We are working on a fix for Sierra right now. It should be ready for testing soon! :slight_smile:


#18

Brendan, our company has the same issue with Adobe Air dragging/dropping in Sierra.

Could you share with me how you guys are getting around the issue? I don’t think we can wait for Adobe/Apple to figure out what’s going on. If you could, that would be great!

An engineer can email me at nate@trainerroad.com. Thanks so much!!!


#19

Hey @Nate_Pearson!

This is something we are still investigating, but it seems like the drag-and-drop Flex call is completely broken in Adobe Air on macOS Sierra. We aren’t going to wait around for Adobe or Apple, but we also aren’t sure how much of this we will be able to workaround considering one of the major functions of the Flex codebase is not working.

Thankfully, this only affects reordering mockups and dragging stuff from the UI library (or outside the app) onto the canvas. The ladder issue can be mitigated by using quick add and the asset manager, it’s the former issue that doesn’t have an easy solution, and that’s what we are focusing on.

We are going to work real hard to have something in folk’s hands by Sierra’s launch, so hang tight. We will keep you in the loop about this as the launch of Sierra gets closer.


#20

Update:

We have a fix for this issue using a beta version of Air that Adobe just released. As soon as I have a testable version for you folks, I will post it. :slight_smile:

Edit: Just for clarity, Mockups 3 on macOS uses an embedded version of Adobe Air, so updating your machine’s version to the beta version won’t help, unfortunately.