[FIXED] Unable to install Balsamiq on Windows 10


#1

Balsamiq Edit: The main issue here was resolved, but if you’re running the most up-to-date installer, and still having trouble, let us know!


Hello, I wanted to install Balsamiq today on my new Windows 10 computer.

I downloaded the installer for the release 3.4.1.

When I double clicked the installer, something went on for a few seconds and then… nothing! Not a file copied, not a window opened, nothing…

I have the latest Adobe Air installed…

Am I the only one with installation troubles?

Best.


#2

Sorry about that, @Bruce_Heller. Let’s see if we can figure out what’s going on.

As much as I hate to ask this, would you mind rebooting your machine and trying to install again? Having nothing happen (no error code or installation screen) leads me to believe that something is preventing the app from installing, especially if you are running the most up-to-date version of Adobe Air. Rebooting may clear that issue out.

If that doesn’t work, shoot us an email at support@balsamiq.com, and we will dig deeper.

In the interim, if you have some wireframing that you need to get done ASAP, you can download and install the stand-alone version of Mockups. Just unzip that archive and run it in place.

Sorry again for the trouble, Bruce. We will do whatever we can to get it sorted!


#3

Sorry but I did that a few times. Still impossible to launch the installer…

I’ll send a mail to the support.

The standalone version works (I did that even before your answer in order to do my work) but is less handy I must say :wink:

Thanks.


#4

I’m seeing the same problem, also on Windows 10. A small dialog appears after starting the installer, titled “Installing Balsamiq Mockups 3” with a progress bar labeled “Please wait.” That hangs around for about five seconds, then the dialog disappears and … nothing.

I reran the installer several times to make sure I wasn’t missing anything, and after perhaps the tenth time a new dialog appeared telling me that Adobe Air was needed. Sure enough, after heading over to adobe.com and installing Air, the Mockups installer worked.

I had downloaded the 3.4.1 installer offered at https://balsamiq.com/download/ (I clicked the Big Blue Button). Nothing on that page suggests (to me) that Air is a prerequisite. Maybe it should?


#5

Thanks for the update @RichA. I’m glad that the Air technique worked for you! :slight_smile:

The installer should be installing Adobe Air as well, which is what makes the whole situation weird. Sometimes Windows gets hung up on the Air portion of the installer, and we aren’t sure why.

I think Bruce (and a couple of others) have run into an even weirder issue. One we are still trying to debug.


#6

Hey, @Bruce_Heller, quick question: Are you Symantec anti-virus on your machine?

If so, would you mind trying the installer again? We forgot to whitelist the 3.4.1 installer with them, but it should be whitelisted now.


#7

I’m seeing the same problem on my Windows 10 machine.

There’s a little popup with a progress bar - says something about verifying download and then closes having not installed anything.


#8

Try downloading and installing Adobe Air first @tkainebliss. That seems to be where Win 10 has been choking :(. After it’s installed, try running the Mockups installer again.


#9

Sorry for the late answer.

@Brendan : no I don’t have Symantec. I use Kaspersky Internet Security and tryed to install Balsamiq without the protection, with no success…

As I told to the support, tryed removing Adobe Air and installing it again, running the installer as administrator… Still with no luck, I don’t even have a popup somewhere, just nothing… Really weird.


#10

Thanks, Bruce.

I just shot you an email with an update. Thanks for helping us test this. :slight_smile:


#11

Hello All,
Today I downloaded, installed, and licensed Balsamiq 3.4.1 on my HP Pavilion Windows 10 computer without a hitch. My computer has all current updates installed.

Regards,
Chris


#12

I’m having the same issue as @RichA only I used installer versioned 3.4.2. I did not have Adobe Air installed. The Balsamiq installer started, showed the dialog with progress bar and then silently went away.

I installed Adobe Air and then reran the Balsamiq installer and it worked correctly. So there appears to still be a problem getting Adobe Air when needed.


#13

I’m having the same issue. I cannot install on Windows 7. I tried rebooting, downloading again, stopping symantec, but issue still persists.


#14

Hey Carlos, I just replied to your email, but I wanted to put a reply here for other folks who may run into this issue.

As of right now, we are still trying to reproduce the issue in-house so that we can get it fixed. I wrote up a quick FAQ for folks who are seeing this issue here because we wanted to have a searchable solution.

Right now, downloading and installing Adobe Air first, and then running our installer, will resolve the issue in 90% of the cases we have seen. We know that, under some circumstances, Windows get’s grumpy when we try to install Air for you, and that’s why our installer fails. Installing air first fixes that.

I’ll keep you all updated on any progress we make, and I’m really sorry for any hassle this is causing folks. We will do everything we can to get it fixed!


#15

Hello @Brendan,

I can not install Balsamiq_Mockups_3.5.5_bundled on windows 10. When I double clicked the installer, something went on for a few seconds and then nothing. I already install Adobe Air. I just sent email to support too.
Can you give me solution to solve the installation troubles?


#16

So sorry for the trouble @ika_ast.

I’ve just replied to your email with a direct link that you may want to try.

I’ll stand by for your email reply and we’ll go from there! :slight_smile:


#17

If you’re installing using Windows 10 you may find that there is an install process already running which will prevent anything else from being installed. Go to Task Manager/Details tab and kill all processes that begin with "msicon. Then try installing Balsamiq again. This worked for me.


#18

You can also download zipped version, labeled With Adobe Air Bundled, unzip the contents and run Balsamiq without installation.